nixp.ru v3.0

17 декабря 2017,
воскресенье,
01:29:04 MSK

DevOps с компанией «Флант»
7 августа 2005, 10:54

Инициатива по прекращению поддержки Linux-ядром старых GCC

Адриан Банк (Adrian Bunk) предложил включить в ветку Linux-релизов -mm патч, убирающий поддержку старых версий GCC в Linux-ядре 2.6.x.

При использовании этого патча ядро уже не сможет быть собрано с GCC 2.95, 2.96, 3.0 и 3.1; останется лишь поддержка версий 3.2, 3.3, 3.4, 4.0.

Общественность в списке рассылки LKM крайне отрицательно отозвалась о присланном патче. Например, при его использовании ядро вообще не сможет быть собрано на платформе VAX, некоторые замечают странные ошибки, проявляющиеся только при сборке последней версией GCC.

Так что ядро будет еще долго поддерживать сборку с использованием GCC 2.95.

Постоянная ссылка к новости: https://www.nixp.ru/news/6400.html. Дмитрий Шурупов по материалам opennet.ru.

fb twitter vk
ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.