nixp.ru v3.0

16 июня 2021,
среда,
22:46:04 MSK

14 апреля 2004, 18:44

Найдена уязвимость в Linux 2.4.x, 2.6.x

Никита Ющенко из МГУ сообщил об обнаруженной в Linux-ядрах веток 2.4.x и 2.6.x уязвимости, приводящей к возможности локального DoS.

Проблема связана с некорректной обработкой ядром завершения нити (thread). В linuxthreads каждой нити соответствует отдельная запись в таблице процессов; именна эта запись для завершившихся (т.е. выполнивших системный вызов exit()) нитей превращается в zombie.

Постоянная ссылка к новости: http://www.nixp.ru/news/3727.html. Дмитрий Шурупов по материалам securityfocus.com.

fb twitter vk