nixp.ru v3.0

26 мая 2017,
пятница,
04:50:40 MSK

DevOps с компанией «Флант»
johncook написал 10 июня 2004 года в 01:07 (240 просмотров) Ведет себя как мужчина; открыл 6 тем в форуме, оставил 16 комментариев на сайте.

Ставил сгодня xine, скачал с офсайта libxine и xine-ui.

Libxine поставил без проблем, а вот со вторым пакетом проблемы — не видит первого:

checking for XINE-LIB version >= 1.0.0… no

* The xine-config script installed by XINE could not be found

* If XINE was installed in PREFIX, make sure PREFIX/bin is in

* your path, or set the XINE_CONFIG environment variable to the

* full path to xine-config.

configure: error: * You should install xine-lib first *

Как лечится? Дистрибутив SuSE 9.0 Pro.

Пытался исправить с помощью ldconfig, хотя в /etc/ld.so.config строчка

/usr/local/lib уже была.

decvar

укажы /path/to/xine-config

см. ./configure --help

ЗЫ

reboot?

johncook

Reboot пробовал…

johncook

Вот нарыл в Xine Faq:

If you have installed xine-lib to a non-standard prefix, make sure that you have $prefix/bin in your PATH and that your linker finds libs in $prefix/lib — otherwise trying to build modules that rely on xine-lib will fail with configure complaining about not finding certain parts of libxine. Using bash you can do something like:

export PATH=«$prefix/bin:$PATH»

export LD_LIBRARY_PATH=«$prefix/lib:$LD_LIBRARY_PATH»

Может мне кто-нибудь объяснить подробно что туда нужно вписать?

johncook

Всё, сделал: export PATH=/usr/local/bin:$PATH

И пошло поехало :)

lid_d

А чем тебе не понравился xine с диска суси?

johncook

Да он какой-то глючный был, включишь — вырубится, да и кодеков маловато было.

Я сейчас ещё win32-кодеки скачал и подрубил, теперь все фильмы идут как по маслу :)