nixp.ru v3.0

29 мая 2017,
понедельник,
01:23:53 MSK

DevOps с компанией «Флант»
Lilit написал 12 ноября 2004 года в 11:51 (253 просмотра) Ведет себя неопределенно; открыл 12 тем в форуме, оставил 63 комментария на сайте.

Допустим, хочу обновить Gimp. Что для этого надо сделать?

Проблема заключается в том, что у меня все гимповые rpm содержат asp.

Вот, поэтому если я загружу обычный rpm и попытаюсь обновить асповый, ничего не выйдет. Чего тогда делать?

На сайте гимповом вообще rpm нет, есть только tar.gz.

Anarchist

rpm -e

rpm -i

RTFM man rpmbuild and/or checkinstall (better rpmbuild)

source installation is unrecommended.

Lilit

Не то… :(

Master
Lilit
Не то… :(

что не то?

Lilit
Master
что не то?

Что толку rpm сооружать, если он все равно не встанет поверх аспового?

Нельзя ли существующий Гимп удалить (вместе с зависимостями) и ставить этот как новый из тар.гз?

Master
Lilit
Нельзя ли существующий Гимп удалить (вместе с зависимостями)

На этот вопрос уже ответил тебе Anarchist:

rpm -e

Lilit
и ставить этот как новый из тар.гз?

Можно. Но все же лучше сделать rpm c помощью checkinstall или собрать rpm из srpm. Установив rpm его потом можно будет легко снести, чего не сделаешь после установки из тар.гз

Lilit
Master
чего не сделаешь после установки из тар.гз

Что — вообще нельзя никак снести???

Вот это да!

Master
Lilit
Что — вообще нельзя никак снести???

Вот это да!

Вообще можно. Я говорю говорию про «легко снести».

Lilit
Master
Вообще можно. Я говорю говорию про «легко снести».

Не скажу, чтобы было легко снести тот же Gimp упомянутой выше командой rpm -e, т.к. куча зависимостей не даст развернуться.

Master
Lilit
Не скажу, чтобы было легко снести тот же Gimp упомянутой выше командой rpm -e, т.к. куча зависимостей не даст развернуться.

Может ключи --force, --nodeps все таки разрулят ситуацию?

Lilit
Master
Может ключи --force, --nodeps все таки разрулят ситуацию?

Может быть…

Только как представлю, сколько всего тут нужно делать, сразу аппетит пропал :).

В конце концов, чем хуже старый гимп. Только вот функцию crop никак у него не найду. Но это уже — отдельная тема.

Genie
Только вот функцию crop никак у него не найду.


Ну, это-то есть… ;))

если основное окошко гимпа сделать так, чтобы кнопочки разместились 5*5, то предпоследняя во втором ряду — как раз оно самое и есть. двойной щелчок — и выбирай, кадрировать (crop) или размер поменять….

Lilit
Genie
Ну, это-то есть… ;))

если основное окошко гимпа сделать так, чтобы кнопочки разместились 5*5, то предпоследняя во втором ряду — как раз оно самое и есть. двойной щелчок — и выбирай, кадрировать (crop) или размер поменять….

А…

Ну thanx тогда.

Curu3MyHg
Lilit

Проблема заключается в том, что у меня все гимповые rpm содержат asp.

Вот, поэтому если я загружу обычный rpm и попытаюсь обновить асповый, ничего не выйдет….

А ты уверена? Конкретно про gimp я не скажу, но в остальном — не возникало у меня проблем с федориными пакетами, разве что пару раз использовал --force. АСП хорошо с ними совместим. Вот с СУСЕшными и Мандрейковыми — это да, хрен что поставишь.

Vladimir

a u menia na mojej fedore stojiat i ASP paketyi mdk, i nichego…

Anarchist
Lilit
Что — вообще нельзя никак снести???

Вот это да!

Можно.

Но для этого надо будет сохранить дерево сырцов, и в Makefile должна быть цель uninstall.

Иначе — лотерея.