nixp.ru v3.0

21 октября 2017,
суббота,
02:34:50 MSK

DevOps с компанией «Флант»
Grinderz написал 18 декабря 2004 года в 07:08 (439 просмотров) Ведет себя как мужчина; открыл 30 тем в форуме, оставил 16 комментариев на сайте.

Здравствуйте

Переустановл SuSE в надежде возобновления звука, но все равно не

пашет.

Извените, за то, что я надаел со своими ламерскими вопросами, но мне очень

нравится SuSE и я хочу настроить звук!

Вот что смог собрать о звуковухе:

linux:/home/grinders # lspci

0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC’97 Audio сontroller (rev 02)

Инфа о моих дровах:

Elitegroup 82801 AC’97 Audio Controller

Driver Info #0:

Driver Status: snd-intel8×0 is not active

Driver Activation Cmd: «modprobe snd-intel8×0»

Driver Info #1:

Driver Status: i810_audio is not active

Driver Activation Cmd: «modprobe i810_audio»

Хочу чтобы работал звук, причем он работает если каждый раз при загрузке запускать YaST и находить звуковуху!

Но это же не выход!

modprobe snd-intel8×0, modprobe i810_audio — это все я пробовал.

файл /etc/modules.conf пуст….

lsmod выдал следующее:

Module Size Used by

usbserial 28912 0

parport_pc 35264 1

lp 10916 0

parport 37704 2 parport_pc,lp

edd 9240 0

joydev 10176 0

st 38940 0

sd_mod 19840 0

sr_mod 15652 0

scsi_mod 107980 3 st,sd_mod,sr_mod

ide_cd 36484 0

cdrom 36508 2 sr_mod,ide_cd

nvram 8328 0

speedstep_lib 3712 0

freq_table 4612 0

snd_seq_oss 30976 0

snd_seq_midi_event 7680 1 snd_seq_oss

snd_seq 54672 5 snd_seq_oss,snd_seq_midi_event

snd_pcm_oss 56868 0

snd_mixer_oss 18688 1 snd_pcm_oss

thermal 12424 0

processor 16040 1 thermal

fan 3972 0

button 6032 0

battery 8580 0

ac 4868 0

ipv6 244100 15

snd_intel8×0 32424 5

snd_ac97_codec 60676 1 snd_intel8×0

snd_pcm 96776 3 snd_pcm_oss,snd_intel8×0

snd_timer 25476 2 snd_seq,snd_pcm

snd_page_alloc 11012 2 snd_intel8×0,snd_pcm

gameport 4736 1 snd_intel8×0

snd_mpu401_uart 7808 1 snd_intel8×0

snd_rawmidi 24992 1 snd_mpu401_uart

snd_seq_device 8328 3 snd_seq_oss,snd_seq,snd_rawmidi

snd 59524 22 snd_seq_oss,snd_seq_midi_event,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_intel8×0,sn

d_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device

soundcore 8800 1 snd

intel_agp 17052 1

agpgart 28712 1 intel_agp

ehci_hcd 27140 0

uhci_hcd 29584 0

usbcore 96988 5 usbserial,ehci_hcd,uhci_hcd

evdev 9600 0

subfs 7296 3

nls_utf8 2176 1

ntfs 86092 1

dm_mod 50044 0

ext3 106664 3

jbd 59044 1 ext3

Теперь звука вообще нет, тока яст видет звуковуху.

если я modprobe какого то модуля делаю, то просто перескакивается на другую строчку и все(результата 0)

Curu3MyHg

Из UNIX-FAQ  с этого же сайта:)

Q: Как заставить работать звуковуху на кодеке AC97 (VIA8233)?

   A: Собираем ядро с поддержкой звуковой карты (default). Cкачиваем с сайта ALSA (http://www.alsa-project.org) файлы alsa-{driver,lib,utils}-xxx.tar.gz (последние стабильные версии этих пакетов). Распаковываем tar-ball’ы: tar zxf alsa-{driver,lib,utils}-xxx.tar.gz Компилим и устанавливаем:

cd alsa-xxxx

./configure

make

make install

   Проделываем это с каждым пакетом. Затем добавляем следующее в /etc/modules.conf:

#ALSA Sound alias

char-major-116 snd

alias snd-card-0 snd-card-via8233

alias char-major-14 soundcore

alias sound-slot-0 snd-card-0

alias sound-service-0-0 snd-mixer-oss

alias sound-service-0-1 snd-seq-oss

alias sound-service-0-3 snd-pcm-oss

alias sound-service-0-8 snd-seq-oss

alias sound-service-0-12 snd-pcm-oss

options snd snd_cards_limit=1

   Теперь загружаем модуль snd-card-via8233:

   /sbin/modprobe snd-card-via8233

   И добавляем эту строку в загрузочный скрипт.

Оно? Ежели чуток подправить?