nixp.ru v3.0

21 октября 2017,
суббота,
19:06:30 MSK

DevOps с компанией «Флант»
Melnix написал 3 сентября 2006 года в 22:44 (397 просмотров) Ведет себя как мужчина; открыл 9 тем в форуме, оставил 24 комментария на сайте.

Есть прога на QT 3.3.3, надо что-бы она работала на QT 4.1.4.

Вопрос, как лучше сделать: использовать Qt3Support4, полностью переписать на QT 4

или писать прогу дальше так чтобы она работала на обоих версиях библиотеки?

P.S. Про последний вариант — я имею в виду структуры типа:

#define QT_3
//#define QT_4
...
#ifdef QT_3
...
#endif
#ifdef QT_4
...
#endif