nixp.ru v3.0

23 января 2017,
понедельник,
17:54:21 MSK

DevOps с компанией «Флант»
xaf написал 13 декабря 2004 года в 04:10 (251 просмотр) Ведет себя неопределенно; открыл 4 темы в форуме, оставил 10 комментариев на сайте.

Я установил драйвера для модема, настроил wvdial.

Дозваниваюсь до провайдера… устанавливается соединение… все как положено… появляется ppp0 интерфейс в ifconfig…

Но ни один сервер не пингуется… не открывается ни одна страница…

Пожалуйста подскажите в каком направлении копать???

Комп: IBM Thinkpad A31

Система: Gentoo 2004.3

Модем : lucent amr

Драйвера: slmodem-2.9.10

Curu3MyHg
xaf
Я установил драйвера для модема, настроил wvdial.

Дозваниваюсь до провайдера… устанавливается соединение… все как положено… появляется ppp0 интерфейс в  ifconfig…

Но ни один сервер не пингуется… не открывается ни одна страница…

Пожалуйста подскажите в каком направлении копать???

Вероятно, в сторону DNS…

xaf

А по конкретнее можно??

metal
А по конкретнее можно??

В /etc/resolv.conf должны быть прописаны адреса dns сервера.

myst

у меня в ppp.conf длм этого написано «enable dns». Но это ppp.conf…

xaf

я в /etc/conf.d/net прописал для интерфайса ppp0 получать ip, адрес dns сервера и тд от прова:

dhcpd_ppp0=«-HD»

пробовал также:

iface_ppp0=«dhcp»

ничего не работает…

Curu3MyHg
xaf
я в /etc/conf.d/net прописал для интерфайса ppp0 получать ip, адрес dns сервера и тд от прова:

dhcpd_ppp0=«-HD»

пробовал также:

iface_ppp0=«dhcp»

У меня нет вообще такого файла, поэтому что это за опции, могу только догадываться.

Ты пробовал вручную прописать адреса DNS-серверов в /etc/resolv.conf? Попробуй их попинговать, хоть станет понятно, действительно ли в DNS проблема.. Кстати, у wvdial есть еще опция Auto DNS..

А может быть, нужно где-нибудь что-то типа опции GATEWAYDEV или DefaultRoute вписать..

xaf

В wvdial autodns включено по умолчанию…

Да, проблема действительно в днс…

Как определить днс не спрашивая в службе??

По моему dhcpcd может это.. вроде с ключем -D он должен автоматически добавлять его в /etc/resolv.conf… но почему то не добавляет???

metal

А в лог wvdial о своих проблемах ничего не пишет?

Как с правами на /etc/resolv.conf, может нет прав туда писать?

myst

Как в Gentoo не знаю, но во FreeBSD в ядре должен быть bpf (Berkeley Packet Filter), чтобы auto-dns работала.

sky

/etc/ppp/options:

.....
usepeerdns
.....
xaf

Все решилось добавлением днс в /etc/resolv.conf

а я то дурак думал что все это автоматически выйдет

не тут то было=)))

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.