nixp.ru v3.0

23 октября 2017,
понедельник,
01:52:01 MSK

DevOps с компанией «Флант»
Gift написал 30 декабря 2004 года в 02:22 (331 просмотр) Ведет себя как мужчина; открыл 5 тем в форуме, оставил 13 комментариев на сайте.

сис-ма FC-3 один раз было такое, что звук сам посебе взял и пропал, лень мне было что-то делать и я просто забил, но потом он так же сам и заработал…

но сейчас снова пропал звук… так же вроде нистого ниссяго….

просто бац и нету…

но если врубаю прогу GQradio то она звук воспроизводит, но ниодин плеер ни аудио не видео не воспроизводит звук…

а до этого единственное что я делал так это просто настраивал плейцлист в радио… просто сроки поменял на DSP:\dev\soundcard и что-то там ещё…..

звковуха какая то на AC’97… непомню вобщем…

scamelscrud

Это кривые дрова (ну может и руки, но я думаю дрова). Были у меня такие проблемы, я ставил дрова с viaarena.com, после чего все работало прекрасно. Но они годятся только на ядра 2.4.

Genie

проверь, для начала, микшер..

ведь программы же запускаются, но при этом просто не выводят звук?

может, кстати, надо тебе настроить неблокирующее проигрывание.

дело в том, что, к примеру, с oss драйверами звука одновременно может выводить вроде бы только одна программа. ну и, так как по имени устройство-то одно, только читать с устройства и записывать в него может тоже ожна программа…. gqradio в твоём случае.

решение такое — поставить alsa версии от 0.9.6, и настроить правильно звук. почитай описание к gqradio, там должно быть по идее это описано…

scamelscrud

Нет, ну что AC’97 неважно работает с дровами из ядер это точно. При смене песни в XMMS запросто может появится сообщение о том, что устройсто недоступно. Нажимаю play, играет дальше, часов через 6 опять может случится. Плюс хрепит иногда. С дровами от via я от этих проблем избавлялся, но теперь у меня 2.6, а драйвера под 2.4…

ЗЫ У меня RH9, но FC3 от него далеко не ушла думаю..

Genie

нет. это лишь говорит о том, что пока xmms думал о смене песенки и собирался там туда что-то выводить, кто-то другой влез и отобрал у него устройство. ;)

вот xmms и обламывается. ;))

ставить alsa, настраивать плагин dmix и не мучиться.

scamelscrud

Genie, кто мог отобрать?=)

У меня это случается даже в таких случаях: я за компом не сижу, крутится заставка (без звука), играет xmms, больше со звуком никто не работает…. и вдруг бац при смене песни xmms обламывается на доступ к устройству.

Вроде отбирать-то некому… вот.

Genie
ставить alsa, настраивать плагин dmix и не мучиться.

и не будет глюков. ;)

можно так же попробовать поставить какой-ниюбудь звуковой сервер. esound, к примеру. (правда, alsa+dmix всё же несколько поудобнее выйдут)

ps: а воткнуть «SB Live! 5.1» (это которая на emu10k) — ещё лучше. даже dmix не надо настраивать.

Vladimir

eto byvajet na OSS. s ALSA takih problem ne zamechialos’.

pomeniaj dlia nachiala v XMMS v nastrojkah audio I/O plugin s OSS na ALSA

DimitriuS
scamelscrud
Genie, кто мог отобрать?=)

Левые демоны типа artsd =)

Curu3MyHg
DimitriuS
Левые демоны типа artsd =)

Угу. У меня именно так и было. И те же симптомы..

http://www.nixp.ru/cgi-bin/forum/YaBB.pl?board=soft;action=display;num=1097623007

Только звук как раз SB Live! 5.1

scamelscrud
DimitriuS
Левые демоны типа artsd =)

А у меня esd…. Он тоже левый?=)

DimitriuS
scamelscrud
А у меня esd…. Он тоже левый?=)

ДА

от подобных демонов отказался уже давно — и не жалею =)

scamelscrud

А какой демон пользовать?

Я без них не могу, сам видишь какая звуковуха..