nixp.ru v3.0

19 января 2017,
четверг,
13:58:02 MSK

DevOps с компанией «Флант»
Аватар пользователя Steck
Steck написал 6 апреля 2005 года в 04:51 (211 просмотр) Ведет себя как мужчина; открыл 124 темы в форуме, оставил 549 комментариев на сайте.

OS: FreeBSD 5.2.1-RELEASE

Видео: NVIDIA

Ставлю Quake3 из портов хочу поиграть…и..

…loading libGL.so.1: QGL_Init: Can’t load libGL.so.1 from /etc/ld.so.conf or current dir: /usr/compat/linux/usr/games/quake3/libGL.so.1: cannot open shared object file: No such file or directory

Что делать? В тем трабла подскажите кто знает

Genie

драйвер видеокарточки поставить, который с сайта nVidia скачивается?

Master
Genie
драйвер видеокарточки поставить, который с сайта nVidia скачивается?

он даже есть в портах

cd /usr/ports/x11/nvidia-driver
anonymous
Steck
OS: FreeBSD 5.2.1-RELEASE

Видео: NVIDIA

Ставлю Quake3 из портов хочу поиграть…и..

…loading libGL.so.1: QGL_Init: Can’t load libGL.so.1 from /etc/ld.so.conf or current dir: /usr/compat/linux/usr/games/quake3/libGL.so.1: cannot open shared object file: No such file or directory

Что делать? В тем трабла подскажите кто знает

Обновиться до 5.4-stable, дальше делать то, что подсказали.

Steck

Дык…

[root(~)] kldstat
Id Refs Address    Size     Name
 3    1 0xc07ca000 4b20a4   nvidia.ko

А обязательно 5.4?

5.3 Подойдет? А то уже выписал..

anonymous
Steck
Дык…

[root(~)] kldstat
Id Refs Address    Size     Name
 3    1 0xc07ca000 4b20a4   nvidia.ko

А обязательно 5.4?

5.3 Подойдет? А то уже выписал..

5.4 — обязательно. В 5.3-Release были жуткие проблемы с ata-дисками. Пока ставил — чертыхался.

anonymous
Steck
Дык…

[root(~)] kldstat
Id Refs Address    Size     Name
 3    1 0xc07ca000 4b20a4   nvidia.ko

А обязательно 5.4?

5.3 Подойдет? А то уже выписал..

А смысл выписывать?

cvsup -g -L 2 src-supfile

less /usr/src/UPDATING

less /usr/src/Makefile

и действуем по инструкции.Быстрее и дешевле чем выписывать ;)

anonymous

у меня прекрасно работает ку3 под 5.3-release

после установки ОС надо установить linux-base (ну или во время установки выбрать соотв. пакет), затем установить драйвер видеокарты (т.к. драйвер при установке проверяет наличие linux-base, и если она обнаружена то устанавливает соотв. модули)

и еще необходимо будет проверить чтобы разрешение экрана в q3config.cfg соответствовало разрешению иксов, или по крайней мере в конфиге иксов должно присутствовать такое разрешение в списке допустимых. (например 1024*768 будет r_mode 6)

anonymous
dmq
у меня прекрасно работает ку3 под 5.3-release

после установки ОС надо установить linux-base (ну или во время установки выбрать соотв. пакет), затем установить драйвер видеокарты (т.к. драйвер при установке проверяет наличие linux-base, и если она обнаружена то устанавливает соотв. модули)

и еще необходимо будет проверить чтобы разрешение экрана в q3config.cfg соответствовало разрешению иксов, или по крайней мере в конфиге иксов должно присутствовать такое разрешение в списке допустимых. (например 1024*768 будет r_mode 6)

Видишь ли, FBSD нужна не только для игр, а еще и для работы пригодится. Как я понимаю, у автора исходного поста установлена 5.3-RELEASE, где, если ты читаешь freebsd-stable@freebsd.org, наличествуют проблемы. Рекомендации обновиться до последней версии — не лишнее.

anonymous

FreeBSD нужна как раз не для игр, но пара великих игр — приятное дополнение ;)

ну а обновление до последних версий — это всегда гуд

Steck

Решил таки обновиться до 5.4 )

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.