nixp.ru v3.0

30 мая 2017,
вторник,
10:18:25 MSK

DevOps с компанией «Флант»
anonymous написал 31 марта 2005 года в 19:47 (277 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

У меня с SuSE 9.0 следующие неприятности.

Мне нужен вьювер .chm файлов. Я ставил себе xchm, но у него жуткие глюки с русским, мало того что все меню иероглифами отображается, так еще и текст. Может как-то решить можно, шрифты какие-нибудь туды-сюды… kchm у меня не встал, зависимости его не удовлетворяют (где QT для Лина скачать?), а их можно обновлять до конца жизни. Может есть все-таки какие-нить вьюверы нормальные (желательно не всякие там плагины к apache и т. п. (ими пользоваться неудобно)) или что-нибудь с xchm сделать.

И второй вопрос по веб-разработке. Что есть хорошего, а то на sourceforge.net набрал php editor и устал нажимать на следующую страницу. Пользовался quanta, не совсем рад его стабильностью, и обращением с кодировками. На Виндовсе когда-то ставил ZendStudio, но этот жрет кучу ресурсов, и к тому же платный, а кряков мне и в форточках хватало, в Пингвине уже не хочется. Вот ZendStudio мне очень даже понравился. Ну меня по большей части интерисует php-редактор. Среди функций: подстветка синтаксиса (php, xhtml), желательно автоматическая вставка, после начала набора какой-нибудь функции, удобство использования и прочие благи, нечто похожее на quanta только можно выкинуть кучу всяких штучек для html, css…

Дам-с, я уже чересчур многовато пишу…

Когда уже SuSE 9.3 выйдет…

fly4life
Belka
У меня с SuSE 9.0 следующие неприятности.

Мне нужен вьювер .chm файлов. Я ставил себе xchm, но у него жуткие глюки с русским, мало того что все меню иероглифами отображается, так еще и текст. Может как-то решить можно, шрифты какие-нибудь туды-сюды… kchm у меня не встал, зависимости его не удовлетворяют (где QT для Лина скачать?), а их можно обновлять до конца жизни. Может есть все-таки какие-нить вьюверы нормальные (желательно не всякие там плагины к apache и т. п. (ими пользоваться неудобно)) или что-нибудь с xchm сделать.

«QT для Лина» (именно для твоего дистрибутива) можно скачать отсюда:

ftp://ftp.suse.com/pub/suse/i386/9.0/suse/i586/

Правда, хочу заметить следующее. Для kchm тебе нужен konqueror, а для него, в свою очередь, необходим установленный KDE. А т.к. я сомневаюсь, что у тебя SuSE установлена без KDE, — думаю, что тебе нужно установить всего лишь пакет qt3-devel-3.2.1-56.i586.rpm, что далеко не есть Qt целиком.

anonymous

Вот ему мой qt-3.2… и не нравится, говорит, что нужен 3.3, а …-devel-3.3…,наверное, без без самого qt-3.3… не встанет. Ладно я сейчас посмотрю на ftp.

Longobard

Проще всего преобразовать .chm в html :)

http://archmage.sourceforge.net/

anonymous

Ну а как на счет веб-редактора?