nixp.ru v3.0

19 октября 2017,
четверг,
06:38:23 MSK

DevOps с компанией «Флант»
grundic написал 22 июля 2005 года в 14:59 (361 просмотр) Ведет себя неопределенно; открыл 3 темы в форуме, оставил 4 комментария на сайте.

При выполнении ./сonfigure пишет такую штуку типа у меня старая глиба 2.0 но я у становил 2.6.5 он пишет все равно вот это месагу:

checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0… Requested 'glib-2.0 >= 2.6.0\′ but version of GLib is 2.2.3

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Помогите плизз!!

8084

1) Какой дистр?!!

2) gtk+ 2.8 — ты нече не путаешь, последняя версия 2.7.5 вроде?

3) glib ставил из сорсов?, а ./configure --prefix=/usr — указал?

Скорее всего либы стоят на уровне /usr, а ты поставил глибу на /usr/local(дефолтный префикс), поэтому и не обнаруживает новые, попробуй собрать глибу с --prefix=/usr

И гтк также, У меня тоже такое было, и я избавился этим оюразом

з.ы. а потом я просто поставил новый дистр.;)

rgo

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig

и ещё

man pkg-config