nixp.ru v3.0

23 мая 2017,
вторник,
23:47:28 MSK

DevOps с компанией «Флант»
ttoorrmmoozz написал 31 марта 2005 года в 21:23 (616 просмотров) Ведет себя неопределенно; открыл 21 тему в форуме, оставил 25 комментариев на сайте.

АСП 9.2

Стоит гном.

При запуске кванты вылетает ошибка .

Оказывается , не может запуститься программа dcopserver ,

которая лежит в том же каталоге /usr/bin , что и кванта .

При запуске dcopserver выдает следующее :

sh: line 1: iceauth: command not found

DCOPClient:attachInternal.Attach failed Authentication Rejected , reason:

None of the authentication protocols specified are supported and

host-based authentication failed ICE Connection rejected

Система сломалась после того , как я эксперементировал с каталогом /tmp

и что-то там затер ручками

Причем проблема в руте.

Не из под рутового пользователя все работает.

Переустановить АСП ?

Но тогда прийдется по новой устанавливать все программы ?

fly4life

Да не, переустанавливать не надо ;)

А если попробовать в домашнем какталоге root’а:

# rm -rf .DCOP* .ICEauthority
ttoorrmmoozz

не помогло

fly4life

а ты как кванту запускаешь? Из консоли, запущенной обычным пользователемв gnome, с помощью «su»? Или же ты gnome запускаешь под рутом и уже оттуда пускаешь кванту?

anonymous

Такое же и у меня произошло. Только тут дело в другом. Все юзеры теперь не могут загрузить KDE с ошибкой с .DCOP*. Зато роот нормально и без боли заходит. Создал нового юзера, тоже не может запуститься dcopserver.

anonymous


$ dcopserver
SocetCreateListener: failed to bind listener
SocetUNIXCreateListener: SocetCreateListener() failed
...
DCOPServer self-test failed.
Could not network connection list.