nixp.ru v3.0

21 октября 2017,
суббота,
09:24:35 MSK

DevOps с компанией «Флант»
hawk написал 19 февраля 2006 года в 19:28 (562 просмотра) Ведет себя неопределенно; открыл 1 тему в форуме, оставил 4 комментария на сайте.

2.4.29 ядро

не устанавливается rpm, так как требует зависиомть:

libstdc++-libc6.1-1.so.2

Стоит glibc стоит версии 2.1.3

и есть файл в /usr/lib/

libstdc++-libc6.1-2.so.3

я делаю мягкий линк на libstdc++-libc6.1-2.so.3 в папках /lib/ и /usr/lib/

но при установке того rpm все равно libstdc++-libc6.1-1.so.2 не найден

ldconfig делал

RPM — пакет установки borland kylix 3. при начале установки он проверяет версию glibc пишет ОК и уходит на установку самого rpm

В чем может быть проблема, помогите пожалуйста!

// Тему переместил(а) fly4life из форума «UNIX FAQ».

fly4life

Насколько я помню, kylix3 требует какую-то древнюю версию glibc, которой в современных дистрибутивах, естесственно, нет. Хотя, в некоторых всё же есть пакеты compat-* (содержащие старые библиотеки для совместимости с устаревшими программами), среди которых может оказаться и нужный тебе compat. Если такого нету (или есть, но kylix всё равно отказывается устанавливаться), то гугл рассказывает про некие патчи для установки kylix3 в современных дистрибутивах:

http://andy.jgknet.de/oss/kylix/wiki/index.php/Main_Page

hawk

Пытаюсь поставить вот это:

rpm -i libstdc++-compat-1.0-6.i386.rpm

И опять невыполеннные зависимости:

libc.so.6

Но этот линк у меня присутствует изначально в /lib/ !

в чем может быть дело?

fly4life

ldconfig забыл сделать? ;)

hawk

нет не забыл.

А может быть такой вариант, что мой libc.so.6 неподходит этому compat?

А вообще у меня стойкое подозрение что в моем линуксе ни одну зависимость найти нельзя! :)) это уже стереотип похоже…

в ld.so.conf:

/usr/X11R6/lib

/usr/lib/qt-1.45/lib

/usr/lib/qt-3.3.3/lib

/usr/lib/qt-2.3.0/lib

fly4life
hawk
нет не забыл.

А может быть такой вариант, что мой libc.so.6 неподходит этому compat?

Ой, так это у тебя неудовлетворённая зависимость при установке compat’а… Видать, ему тоже нужен какой-то compat-пакет (тот же compat-glibc)?

hawk
А вообще у меня стойкое подозрение что в моем линуксе ни одну зависимость найти нельзя! :)) это уже стереотип похоже…

Что за линукс-то?

hawk

МСВС 3.0

:D

hawk

фуф…

И стал я искать в каком RPM лежит нужный мне libstdc++-libc6.1-1.so.2

google помог и выдал целый список.

я все их и скачал.

начал ставить по одному

А Один из этого списка встал!!! И с этих пор kylix3 пошел инсталиться!!! Как я рад!!

Извините в линуксе 2 день!!