nixp.ru v3.0

25 мая 2017,
четверг,
06:13:16 MSK

DevOps с компанией «Флант»
danikcom написал 3 августа 2006 года в 04:48 (7402 просмотра) Ведет себя как мужчина; открыл 52 темы в форуме, оставил 132 комментария на сайте.

часто возникает проблема с PKG_CONFIG_PATH при конфиге ПО с исхдников

например делаю ./configure одного из ПО и вот ошибка при конфиге

.....
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GDU_MODULE_VERSION_CHECK... Package gnome-doc-utils was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnome-doc-utils.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gnome-doc-utils' found
configure: error: Package requirements (gnome-doc-utils >= 0.3.2) were not met:
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GDU_MODULE_VERSION_CHECK_CFLAGS
and GDU_MODULE_VERSION_CHECK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

беру устанавливаю последнюю версию этого gnome-doc-utils из исходников и всеравно выдает эту ошибку…

почему? ведь я установил его, а он

No package 'gnome-doc-utils' found
configure: error: Package requirements (gnome-doc-utils >= 0.3.2) were not met:

что делать?

cyb3rpunk

Попробуй что-нить вроде export PKG_CONFIG_PATH=«$PKG_CONFIG_PATH:путь_до_gnome-doc-utils»

И, конечно, RTFM:)

помогло

export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:путь"

где путь=путь_до_pkgconfig_где_лежит_*.pc

только вот вопросы:

1. куда она его экспортировала? т.е. ненадо при следующей загрузке экспортировать его снова? в каком файле указываютя эти пути?

2. и что означает

checking for LIB... Requested 'gtk+-2.0 >= 2.8.15' but version of GTK+ is 2.4.13
configure: error: Package requirements (gtk+-2.0 >= 2.8.15 libgnomeui-2.0 >= 2.14.0) were not met:

мне нужно gtk+ больше версии 2.0 или 2.8.15?

и соответственно libgnomeui 2.0 или 2.14.0?

3. сразу спрошу, у меня gtk+-1.2.10, если я установлю новую, проблем с другими ПО не будет?

4. я прописал

export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig"

и когда ввожу echo $PKG_CONFIG_PATH выдает путь разумеется

:/usr/local/lib/pkgconfig

а как же стандартный путь :/usr/lib/pkgconfig? он будет искать в нем необходимые библиотеки?

myst

Будет. Только стандартный (как и все пути) без :. : из-за того, что сначала PKG_CONFIG_PATH="» => $PKG_CONFIG_PATH:/path_to_pcs == «":/path_to_pcs == :/path_to_pcs

Вот.

cyb3rpunk

Существуют, так сказать две разных GTK+: GTK+ и GTK+ 2.0, это можно сказать, разные вещи, тебе нужно GTK+ 2.0 версии 2.8.15, libgnomeui-2.0 версии 2.14.0. А вообще, то, что чтоит слева от знака равенства — название пакета, а справа — его версия.