nixp.ru v3.0

23 мая 2017,
вторник,
23:52:38 MSK

DevOps с компанией «Флант»
Аватар пользователя neGODnick
neGODnick написал 26 июня 2007 года в 04:20 (819 просмотров) Ведет себя как мужчина; открыл 8 тем в форуме, оставил 81 комментарий на сайте.

Ничем не могу посмотреть файлы .chm!

       

kchmviewer version 2.7 http://www.kchmviewer.net/ — пишет, что мол,

«ошибка открытия файла …путь такой-то/кракозябры.htm

файл или директория …путь такой-то/кракозябры.htm не существует»

GnoCHM (Просмотрщик CHM) 0.9.9 и

HelpExplorer 3.0 (starthelp) http://www.ichip.ru/download/index.php?id=3021 и http://www.help-explorer.com/

Эти два просто открывают «пустой» файл. У HelpExplorer к тому же все шрифты интерфейса уехали, но это уже не суть.

Anarchist
neGODnick
Ничем не могу посмотреть файлы .chm!

kchmviewer version 2.7 http://www.kchmviewer.net/ — пишет, что мол,

«ошибка открытия файла …путь такой-то/кракозябры.htm

файл или директория …путь такой-то/кракозябры.htm не существует»

Как ставил? Все зависимости соблюдены?

Что у тебя с настройками системной локали (хотя это замечание относится скорее к gtk2-приложениям с отличной от UTF8 локалью)?

У меня kchmviewer, правда версии 2.5, замечательно работает.

Никаких проблем (в том числе на этапе установки) отмечено не было.

neGODnick

HelpExplorer 3.0 — из бинарников вроде с офф. сайта (HelpExplorer3.0_LINUX.tar.gz), остальные — через Установка\удаление программ вроде.

Поискал в сети — может мне нужен chmlib?

Делаю:

sudo apt-get install chmlib
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакет chmlib недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
  libchm1
E: Для пакета chmlib не найдены кандидаты на установку

Что делать дальше?

Synaptic показал, что пакет libchm1 версии 2:0.39-2 (самый свежий) в системе уже установлен. Однако не установлены libchm-bin и libchm-dev. Ставить их, что ли?

Или ставить chmlib-0.39.tar.gz, который я скачал?

Как зависимости проверить того, что уже стоит?

————————————-

Локаль не помню, а как узнать — ещё не научился

neGODnick

Вот посмотрел зависимости для GnoCHM:

Делаю что рекомендовано:

sudo apt-get install python-cjkodecs
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
E: Не могу найти пакет python-cjkodecs

РРРРРРРРРР….

Anarchist

ЕМНИП по зависимостям доставлялось только:

$ eix chmlib
[I] app-doc/chmlib
     Available versions:  0.39
     Installed versions:  0.39(01:28:55 03.05.2007)
     Homepage:            http://www.jedrea.com/chmlib/
     Description:         Library for MS CHM (compressed html) file format plus extracting and http server utils

Никаких проблем не возникало.

Мораль: наверное придётся изучить пакетную систему выбранного дистрибутива.

neGODnick

Щас не было времени разбираться досконально, но установил более свежую версию kchmviewer_3.1-1~getdeb1_i386.deb по ссылке http://www.getdeb.net/app.php?name=KchmViewer.

При установке было сообщено, что все зависимости соблюдены.

Однако не работает.

Anarchist

И ты абслютно уверен что файл не битый и соответствует стандартам?

myst

Я xchm пользуюсь. Пока сбоев не было.

dmitriy_

Попробуй еще kchm-0.6.5, если это не тоже самое

Diozan

kchmviewer

Настройки-Изменить настройки-Зависимые от версии настройки-основанный на QTextBrowser