nixp.ru v3.0

18 октября 2017,
среда,
01:06:43 MSK

DevOps с компанией «Флант»
Heavy написал 15 апреля 2008 года в 18:52 (596 просмотров) Ведет себя как мужчина; открыл 55 тем в форуме, оставил 698 комментариев на сайте.

Поставил себе фрю 7-RELEASE, поднял ftpd — вроде норм работает. Но упорно не хочет chroot’ить по правилу из ftpd.conf.

——--

ftpchroot:

user1

ftpd.conf:

chroot all /var/spool/ftp

———--

user1 в ftpusers не прописан. При таком раскладе chroot производится в домашний каталог юзера, как будто ftpd.conf игнорится. Это я накосячил или это баг/фича?

Anarchist

Ты встроенный ftpd как пускаешь (из-под inetd или standalone)?

Если standalone, то добавь в список флагов '-d' и попробуй почитать лог.

Heavy

через inetd. А в логе ничего по этому поводу нет

Anarchist
Heavy
через inetd. А в логе ничего по этому поводу нет

Для стандартного варианта запуска — оно и неудивительно.

Попробуй как standalone в режиме отладки.

/etc/rc.conf:

inetd_enable="NO"
ftpd_enable="YES"               # Enable stand-alone ftpd.
ftpd_program="/usr/libexec/ftpd" # Path to ftpd, if you want a different one.
ftpd_flags="-d"                   # Additional flags to stand-alone ftpd.