nixp.ru v3.0

18 октября 2017,
среда,
14:19:56 MSK

DevOps с компанией «Флант»
tamias написал 9 августа 2008 года в 07:11 (1544 просмотра) Ведет себя как мужчина; открыл 1 тему в форуме.

Добрый день!

Ищу неспешно помощи в установке Network UPS Tools под Mac OSX.

Необходим для мониторинга APC Back-UPS CS 650IE + iMac(Intel)+Mac OSX 10.5.4

пробовал самостоятельно компилировать и ставить из пакета  nut-2.2.2.tar.gz, но не смог настроить,  это отдельная тема, и я  воспользовался инструкцией :

http://boxster.ghz.cc/projects/nut/wiki/NutOnMacOSX

и установил пакет nut-2.0.5-1 при помощи Fink. Он установил все в /sw/etc/nut/

установил, вроде заработал,  вот установки:

1. /sw/etc/nut/ups.conf

<font color=«green»>[CS_650]</font>

<font color=«green»>  driver = newhidups</font>

<font color=«green»>  port = /dev/ttyS1</font>

2. /sw/etc/nut/upsd.conf

<font color=«green»>ACL all 0.0.0.0/0</font>

<font color=«green»>ACL localhost 127.0.0.1/32</font>

<font color=«green»>ACCEPT localhost</font>

<font color=«green»>REJECT all</font>

3. /sw/etc/nut/upsd.users

<font color=«green»>[nobody]</font>

<font color=«green»>   password  =</font>

<font color=«green»>   allowfrom = localhost</font>

<font color=«green»>   upsmon master</font>

4. /sw/etc/nut/upsmon.conf

<font color=«green»>MONITOR CS_650@localhost 1 nobody master</font>

если есть ошибки , укажите.

Затем в терминале вот такие команды и ответы (зеленым):

1. sudo /sw/lib/nut/upsdrvctl start:

<font color=«green»>iMac:~ tamias$ sudo /sw/lib/nut/upsdrvctl start</font>

<font color=«green»>Password:</font>

<font color=«green»>Network UPS Tools — UPS driver controller 2.0.5</font>

<font color=«green»>Network UPS Tools: 0.28 USB communication driver 0.28 — core 0.30 (2.0.5)</font>

<font color=«green»>Detected a UPS: American Power Conversion/Back-UPS CS 650 FW:817.v4.I USB FW:v4</font>

<font color=«green»>Using subdriver: APC/CyberPower HID 0.9</font>

2. sudo upsd

<font color=«green»>iMac:~ tamias$ sudo upsd</font>

<font color=«green»>Network UPS Tools upsd 2.0.5</font>

<font color=«green»>/sw/var/run/ups is world readable</font>

<font color=«green»>/sw/etc/nut/upsd.conf is world readable</font>

<font color=«green»>Connected to UPS [CS_650]: CS_650</font>

<font color=«green»>/sw/etc/nut/upsd.users is world readable</font>

3. sudo upsmon

<font color=«green»>iMac:~ tamias$ sudo upsmon</font>

<font color=«green»>Network UPS Tools upsmon 2.0.5</font>

<font color=«green»>UPS: CS_650@localhost (master) (power value 1)</font>

<font color=«green»>Using power down flag file /etc/killpower</font>

и почему то постоянно меняется соединение:

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 22:35 JST…</font>

<font color=«green»>Communications with UPS CS_650@localhost lost</font>

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 22:35 JST…</font>

<font color=«green»>Communications with UPS CS_650@localhost established</font>

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 22:36 JST…</font>

<font color=«green»>Communications with UPS CS_650@localhost lost</font>

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 22:36 JST…</font>

<font color=«green»>Communications with UPS CS_650@localhost established</font>

и т д , но тем не менее cм. 5. пункт.

4. auxwww | grep ups

<font color=«green»>iMac:~ tamias$ ps auxwww | grep ups</font>

<font color=«green»>nobody     814   0.0  0.0   698028    460   ??  Ss   10:33pm   0:00.01 /sw/lib/nut/newhidups -a CS_650</font>

<font color=«green»>root       231   0.0  0.0    78428    748   ??  Ss    8:39pm   0:02.51 apcupsd stop</font>

<font color=«green»>tamias   821   0.0  0.0   599820    468 s000  S+   10:35pm   0:00.00 grep ups</font>

<font color=«green»>nobody     819   0.0  0.0   599656    248   ??  S    10:34pm   0:00.00 upsmon</font>

<font color=«green»>root       818   0.0  0.0   599652    196   ??  Ss   10:34pm   0:00.00 upsmon</font>

<font color=«green»>nobody     816   0.0  0.0   599660    232   ??  Ss   10:34pm   0:00.01 upsd</font>

5. upsc CS_650@localhost

<font color=«green»>iMac:~ tamias$ upsc CS_650@localhost</font>

<font color=«green»>battery.charge: 100</font>

<font color=«green»>battery.charge.low: 10</font>

<font color=«green»>battery.charge.warning: 50</font>

<font color=«green»>battery.date: 2007/02/13</font>

<font color=«green»>battery.mfr.date: 2007/02/13</font>

<font color=«green»>battery.runtime: 1312</font>

<font color=«green»>battery.runtime.low: 120</font>

<font color=«green»>battery.temperature: 28</font>

<font color=«green»>battery.type: PbAc</font>

<font color=«green»>battery.voltage: 13.5</font>

<font color=«green»>battery.voltage.nominal: 12.0</font>

<font color=«green»>driver.name: newhidups</font>

<font color=«green»>driver.parameter.port: /dev/ttyS1</font>

<font color=«green»>driver.version: 2.0.5</font>

<font color=«green»>driver.version.data: APC/CyberPower HID 0.9</font>

<font color=«green»>driver.version.internal: 0.30</font>

<font color=«green»>input.voltage: 178.0</font>

<font color=«green»>input.voltage.nominal: 230</font>

<font color=«green»>output.voltage: 230.0</font>

<font color=«green»>output.voltage.nominal: 230.0</font>

<font color=«green»>ups.beeper.status: enabled</font>

<font color=«green»>ups.delay.shutdown: -1</font>

<font color=«green»>ups.firmware: 817.v4.I</font>

<font color=«green»>ups.firmware.aux: v4</font>

<font color=«green»>ups.load: 27.0</font>

<font color=«green»>ups.mfr: American Power Conversion</font>

<font color=«green»>ups.mfr.date: 2007/02/13</font>

<font color=«green»>ups.model: Back-UPS CS 650</font>

<font color=«green»>ups.power.nominal: 566</font>

<font color=«green»>ups.serial: QB0707231626</font>

<font color=«green»>ups.status: OL</font>

<font color=«green»>ups.test.result: No test initiated</font>

теперь оставалось установить какой-нибудь клиент и попробовать мониторинг.

Но после перезагрузки что-то поменялось

<font color=«green»>iMac:~ tamias $ sudo /sw/lib/nut/upsdrvctl start</font>

<font color=«green»>Network UPS Tools — UPS driver controller 2.0.5</font>

<font color=«green»>Network UPS Tools: 0.28 USB communication driver 0.28 — core 0.30 (2.0.5)</font>

<font color=«green»>Detected a UPS: American Power Conversion/Back-UPS CS 650 FW:817.v4.I USB FW:v4</font>

<font color=«green»>Using subdriver: APC/CyberPower HID 0.9</font>

<font color=«green»>iMac:~ tamias $ sudo upsd</font>

<font color=«green»>Network UPS Tools upsd 2.0.5</font>

<font color=«green»>Can’t bind TCP port number 3493: Address already in use</font>

<font color=«green»>iMac:~ tamias $ sudo upsmon</font>

<font color=«green»>Network UPS Tools upsmon 2.0.5</font>

<font color=«green»>UPS: CS_650@localhost (master) (power value 1)</font>

<font color=«green»>Using power down flag file /etc/killpower</font>

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 11:09 JST…</font>

<font color=«green»>Communications with UPS CS_650@localhost lost</font>

<font color=«green»>Broadcast Message from tamias@iMac.local</font>

<font color=«green»>       (no tty) at 11:09 JST…</font>

<font color=«green»>UPS CS_650@localhost is unavailable</font>

ну и остальные я не привожу.

Надеюсь на любую помощь.