nixp.ru v3.0

24 января 2017,
вторник,
18:14:22 MSK

DevOps с компанией «Флант»
ytyflj написал 21 ноября 2008 года в 15:15 (425 просмотров) Ведет себя неопределенно; открыл 1 тему в форуме, оставил 1 комментарий на сайте.

в общем попытался ставить pidgin, вылетает такая ошибка

checking for GLIB… no

no

configure: error:

You must have the GLib 2.0 development headers installed to build.

If you have these installed already you may need to install pkg-config so

I can find them.

Че мне делать, как быть?

зы. у мну убунта 8.04, pkg-config 0.22-1

myst

Как ставил? Из исходников собирал поди?

sky

aptitude install pidgin — уже не катит?

ytyflj

myst, кроме исходников ничего не было для убунты :(

sky, я чайник, поподробнее плз

myst

Ага, и английский ты не знаешь совсем… А сколько лет тебе, дитя?

Дмитрий Шурупов
ytyflj
myst, кроме исходников ничего не было для убунты :(

Что за новости?

Выполни в консоли и забудь о проблемах:

sudo apt-get install pidgin

P.S. И очень рекомендую почитать цикл «Ubuntu для новичков» из недавних выпусков osa.samag.ru. В последнем — как раз про управление ПО. Чтобы раз и навсегда забыть про сборку популярных пакетов из исходников в Ubuntu…

ss1

обычно pidgin уже идет встроенный, у меня в дистре был уж!!

но

apt-get install pidgin рулит :-)

GooglieS

Если так уж хочется собрать из исходников, то перед тем как — надо поставить необходимые либы для этого. Делать так:

sudo apt-get build-dep pidgin

Dmitry.Stolyarov

А сама ошибка при сборке возникла потому, что нет «базовых файлов для сборки». Что в них входит конкретно — черт знает, но там как минимум основные заголовочные и libc…

Для того, чтобы поставить эти самые «базовые файлы» нужно:

sudo apt-get install build-essential

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.