nixp.ru v3.0

29 мая 2017,
понедельник,
12:38:17 MSK

DevOps с компанией «Флант»
cyb3rpunk написал 18 декабря 2008 года в 10:01 (556 просмотров) Ведет себя как мужчина; открыл 17 тем в форуме, оставил 201 комментарий на сайте.

Сегодня обновилась cpanel. Апач не запускается, при попытке запуска выдает

# /usr/local/apache/bin/apachectl start
Syntax error on line 211 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/lib/libX11.so.6: Undefined symbol "__sbtolower"
/usr/local/apache/bin/apachectl start: httpd could not be started

Система FreeBSD 6.2-RELEASE

Apache/1.3.37

PHP 5.2.6

Версию cpanel узнать не представляется возможным, ибо она тоже умерла.

А вот зачем он пытается libX11, ума не приложу.

Ulysses
cyb3rpunk
Syntax error on line 211 of /usr/local/apache/conf/httpd.conf:

А показать фрагмент конфига вблизи этой строчке запрещает СБ предприятия?

cyb3rpunk

Там ничего особенного, обычное подключение php. А язвить и я умею.

LoadModule rewrite_module     libexec/mod_rewrite.so
LoadModule expires_module     libexec/mod_expires.so
#################################################
LoadModule php5_module        libexec/libphp5.so
##################################################
LoadModule bwlimited_module   libexec/mod_bwlimited.so
LoadModule bytes_log_module   libexec/mod_log_bytes.so
LoadModule auth_passthrough_module libexec/mod_auth_passthrough.so
Ulysses

Ну если httpd.conf приведён дословно, и ругается сервер на эту строчку:

LoadModule php5_module libexec/libphp5.so

Таки имеет смысл пересобрать php