nixp.ru v3.0

25 мая 2017,
четверг,
21:14:09 MSK

DevOps с компанией «Флант»
Nuclear написал 28 марта 2004 года в 15:06 (1989 просмотров) Ведет себя как мужчина; открыл 27 тем в форуме, оставил 65 комментариев на сайте.

Добрый время суток.

Недавно столкнулся с одной небольной проблемой в Mandrake 9.1

После запуска иксов не могу переключаться между терминалами с помощью клавиш CTRL+ATL+F*. Хотя на других дистрибутивах без проблем все работает.

Где необходимо подкрутить, что настроить?

anonymous

У меня mandrake 10

и работает

anonymous

2 Nuclear: Начни отсюда:

http://www.nixp.ru/cgi-bin/forum/YaBB.pl?board=faq;action=display;num=1073764938

2 aviss: У меня Slackware current, и тоже все работает, но как этот факт поможет Nuclear?

Good Luck,

UT

Nuclear

После реадктирования конфига Xов (замены «group_led» на default+group_led)

результатов никаких. Оно и правельно, ведть вышеописанные строки решения проблемы когда комбинации спец. клавиш не работают в не латинской раскладке клвиатуры). У меня немного по другому: Не работаю лишь комбинации CTRL+ALT+Fn при любой раскладке, но корректно работают другие сочетания (CTRL+ALT+Backspace) при ЛЮБОЙ раскладке.

anonymous

А они есть, эти виртуальные консоли? Посмотри в /etc/inittab Должно быть

# Run gettys in standard runlevels

1:2345:respawn:/sbin/mingetty tty1

2:2345:respawn:/sbin/mingetty tty2

3:2345:respawn:/sbin/mingetty tty3

4:2345:respawn:/sbin/mingetty tty4

5:2345:respawn:/sbin/mingetty tty5

6:2345:respawn:/sbin/mingetty tty6

в конце. Или набери как рут

init 3

и посмотри, что получится. Будут дополнительные консоли после Alt+F# или нет

Good Luck,

UT

Nuclear

Терминалы конечно есть. Я работаю под консолью, но иногода запускаю Иксы и хотелосьбы пользоваться виртуальными терминанлами, а ни терминалами в окошках.

Genie

man XF86Config-4

на предмет

Section "ServerFlags"
      Option      "DontZap"      "true"
      Option      "VTSysReq"      "true"
EndSection
Nuclear

Редактировал конфиг иксов с предложенными параметрами, но результат отрицательный.

Опция Option «DontZap» «true» успешно работает.

Но Option «VTSysReq» «true» результатов не дает никаких

Также пробывал Option «DontVTSwitch» «false», тоже результатов 0. Хотя в мане пишеться что этот параметр отвечает именно за разрешение переключения между терминалами.

Genie

В мане пишется, что если опция VTSysReq включена (on|true), то переключение производится Alt+SysRq и потом Fx.

Nuclear

Что-то у меня не получаеться. К конфиге иксов все правильно написано, но переключиться не получаеться. Все делаю как положенно (насколько я понимаю SysRq это Prt Scr).

Сначала ALT+SysRq потом Fn (F1…F6) и ничего.

Странно…

У меня раньше переключение между VT происходило обычным способом CTRL+ALT+Fn, что необходимо прописать к конфиге чтобы в данном случаю тоже использовать такую компинацию.

DontVTSwitch не работает.