nixp.ru v3.0

22 мая 2017,
понедельник,
20:31:07 MSK

DevOps с компанией «Флант»
Longobard написал 3 апреля 2004 года в 19:18 (456 просмотров) Ведет себя как мужчина; открыл 291 тему в форуме, оставил 2499 комментариев на сайте.

Скачал MPlayer 0.90. Распаковываю, делаю ./configure --enable-gui --enable-x11 .Вылетает ошибка конфигура:

Error: X11 support required for GUI compilation

Шозанах? Я же указал: --enable-x11

Чего делать?

anonymous

А на фига тебе 0.90, уже 0.92 есть. И не пиши --enable-x11

Longobard

Пробовал не писать. Все равно то же самое

anonymous

А на какой системе собираешь? xlib-devel, XFree-devel пакеты установлены?

Longobard

да.

anonymous

Похоже, она не находит иксовых хедеров и библиотек. Попробуй указать их явно (опции --with-x11incdir=DIR и --with-x11libdir=DIR )

Вот строка из configure, которая выдает твою ошибку:

test «$_x11» != yes && die «X11 support required for GUI compilation»

А переменная $_x11 определяется выше как наличие хедера /usr/X11/include/X11/Xlib.h и библиотек /usr/X11R6/lib/libX11.so и /usr/X11R6/lib/libX11.a

Посмотри еще ldconfig

Longobard

Сенькс, буду мучицца :)

Vima

Что-то, помницца, у меня такая же фигня была. В попытках поставить гуевую версию я отчаялась, плюнула на все это. Поставила только консольную. Какая разница, если функции все те же самые.