nixp.ru v3.0

22 октября 2017,
воскресенье,
07:30:29 MSK

DevOps с компанией «Флант»
Longobard написал 24 мая 2004 года в 19:00 (338 просмотров) Ведет себя как мужчина; открыл 291 тему в форуме, оставил 2499 комментариев на сайте.

Не работают русские шрифты в GTK прогах (mozilla, xchat, GIMP, dia, etc…). У меня прописана локаль koi8-r, русские шрифты в иксах есть (поставлены). Я прописал в ~/.gtkrc следующие строки:

style "gtk-default-ru"
{
fontset="-*-courier new-medium-r-*-*-13-*-*-*-*-*-koi8-r"
}
class "GtkWidget" style "gtk-default-ru"

В том что такой шрифт есть — я уверен, т.к. он у меня прописан в конфиге флукса и с ним пускаются все терминалы и пр. Короче чего еще сделать? А то в GTK прогах квадратики вместо руссиша :(

Xwine

это говорит о том что у тебя с конфиге Хов не прописан путь

к русским фонтам или ты не делал fc-cache

Longobard

Млять, я же говорю. Этот шрифт я юзаю в флуксе и он у меня прописан в терминалах. То есть я его уже использую во всех не-GTK прогах.

Genie

Ну, а в gtkfontsel оно у тебя есть?

Longobard

у меня нету gtkfontsel :(

decvar

В gtk2.x настройки шрифтов берутся из gnome-settings-daemon, который связан с gconfd. Соответстенно тебе надо настроить шрифты нативными гономовскими тулзами, и все будет.

Кстати ~/.gtkrc — это настройки для gtk1.x

равно как и /etc/gtk/gtkrc.X

шрифты для gtk1.x(и для Иксов ваще) смотрятся в xfontsel

Longobard

Дык мне что из-за этого гном ставить? У меня флукс стоит. А как-нить без нативных гномовских побрякушек можно обойтись?