nixp.ru v3.0

22 октября 2017,
воскресенье,
02:18:02 MSK

DevOps с компанией «Флант»
anonymous написал 6 февраля 2005 года в 14:26 (472 просмотра) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Я установил у себя пакет qt-dev , он лег в каталог /usr/lib/qt-3.3

Но установил как-то некорректно , кажется с ключом --nodeps.

После чего когда я пытаюсь собрать какую-нибудь программу с использованием

этой библиотеки , у меня вываливается ошибка примерно такая :

checking for Qt … configure: error: Qt (>= Qt 3.2) (library qt-mt) not found.

Я так понимаю , что нужно где-то как-то прописать пути к ней.

aivs

в /etc/ld.so.conf

допиши поуть к либам: /usr/lib/qt-3.3

и сделай ldconfig

aivs

и еще в каталоге с /usr/lib/qt-3.3-где либы лежат, сделай

ln -s libqt.so.3.3.3 libqt-mt.so

ln -s libqt.so.3.3.3 libqt-mt.so.3

ln -s libqt.so.3.3.3 libqt-mt.so.3.3

ln -s libqt.so.3.3.3 libqt-mt.so.3.3.3

а потом lgconfig