nixp.ru v3.0

19 января 2017,
четверг,
07:30:17 MSK

DevOps с компанией «Флант»
anonymous написал 10 февраля 2005 года в 08:57 (235 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

дистрибутив Slackware10

Вообщем вопрос такой точнее проблемка ! создаю vpn соединение к интернету ! запускаю pptp Вроде как конектица с серваком (предоставляется внешний IP ,маска назначается тоже правельно ) но непингуется ниодин инет-адрес и даже сервак который предоставил мне внешний ip ! думал дело в статическиж маршрутах …Так нет же !Всё прописано правильно ! вместе с админом сидели и рассматривали данную проблемку ! ничего невышло !

Где грабли ? может кто нибудь подскажет ? ! А вот собственно и таблицы !

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

main.tsgnet.ru * 255.255.255.255 UH 0 0 0 ppp1

10.0.1.0 10.0.3.1 255.255.255.0 UG 0 0 0 eth0

10.0.3.0 * 255.255.255.0 U 0 0 0 eth0

loopback * 255.0.0.0 U 0 0 0 lo

default main.tsgnet.ru 0.0.0.0 UG 0 0 0 ppp0

где main.tsgnet.ru ( адрес сервака VPN)

10.0.1.0 — локальный (внутренний адрес ) сервака

10.0.3.0 — адрес нашей части (района сети ,ну или как его там )

10.0.3.1- шлюз до сервака

И так где же грабли ?

fly4life

Пинговать пробуешь по имени или по IP адресу? Может с настройками DNS-серверов не всё в порядке?

Genie

довольно странная таблица маршрутизации..

что-то не то. покажи также вывод ifconfig при установленном соединении.

Picasso

вот то что выдаёт ifconfig :

eth0 Link encap:Ethernet HWaddr 00:01:03:D0:C4:0C

inet addr:10.0.3.243 Bcast:10.0.3.255 Mask:255.255.255.0

UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1

RX packets:284291 errors:0 dropped:0 overruns:1 frame:0

TX packets:747 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:72981023 (69.6 Mb) TX bytes:57384 (56.0 Kb)

Interrupt:16 Base address:0xb400

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1647 errors:0 dropped:0 overruns:0 frame:0

TX packets:1647 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:48141 (47.0 Kb) TX bytes:48141 (47.0 Kb)

ppp0 Link encap:Point-to-Point Protocol

inet addr:80.237.74.95 P-t-P:80.237.74.2 Mask:255.255.255.255

UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1452 Metric:1

RX packets:84 errors:36 dropped:0 overruns:0 frame:0

TX packets:79 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:3

RX bytes:3489 (3.4 Kb) TX bytes:3333 (3.2 Kb)

fly4life

Хм, а мой ворос почему-то проигнорировали…

Picasso

Да нет же говорю что вообще непингуется никак ! ! !

А что самое интересное что даже Ip (внешний) сервака(80.237.74.2 ) , который мне предоставил адрес (80.237.74.95 ),тоже пинга нет !!! :(

Genie

тек-с.. ну, насколько я понимаю технологию.

первоначально у тебя должна быть где-то вот такая таблица маршрутов

Kernel IP routing table
Destination     Gateway         Genmask          Flags  Metric Ref    Use Iface
10.0.3.0        *               255.255.255.0    U      0      0        0 eth0
loopback        *               255.0.0.0        U      0      0        0 lo


(самодеятельность в виде 10.0.1.0/24 выкинул)

после этого, при установке vpn-соединения (до, видимо, сервера 10.0.3.1) у тебя должен появиться интерфейс ppp0.

и таблица должна поменяться на типа

Kernel IP routing table
Destination     Gateway         Genmask          Flags  Metric Ref    Use Iface
80.237.74.2     *               255.255.255.255  UH     0      0        0 ppp0
10.0.3.0        *               255.255.255.0    U      0      0        0 eth0
loopback        *               255.0.0.0        U      0      0        0 lo
default         80.237.74.2     0.0.0.0          UG     0      0        0 ppp0

что как раз и будет означать, что у тебя всё нормально.

Picasso

Дело в том что vpn — сервер это 10.0.1.1 , а 10.0.3.1 это шлюз к нему.

таким образом (10.0.1.0/24 ) я пытался пробить статический маршрут ,Но видимо я коряво этоделаю или я чтото недопонял !

Вообщето до этого я работал с ASP Linux итам такое работало !

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

80.237.74.2 * 255.255.255.255 UH 0 0 0 ppp0

10.0.1.0 10.0.3.1 255.255.255.0 UG 0 0 0 eth0

10.0.3.0 * 255.255.255.0 U 0 0 0 eth0

loopback * 255.0.0.0 U 0 0 0 lo

default 80.237.74.2 0.0.0.0 UG 0 0 0 ppp0

root@slack:/home/piff# ping 80.237.74.2

PING 80.237.74.2 (80.237.74.2) 56(84) bytes of data.

— 80.237.74.2 ping statistics —

7 packets transmitted, 0 received, 100% packet loss, time 5998ms

ПРичём даже сервак непингуется ! :(

————————————————————————————————————————-

root@slack:/home/piff# ifconfig

eth0 Link encap:Ethernet HWaddr 00:01:03:D0:C4:0C

inet addr:10.0.3.243 Bcast:10.0.3.255 Mask:255.255.255.0

UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1

RX packets:40500 errors:0 dropped:0 overruns:1 frame:0

TX packets:946 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:3948070 (3.7 Mb) TX bytes:63876 (62.3 Kb)

Interrupt:16 Base address:0xb400

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:204 errors:0 dropped:0 overruns:0 frame:0

TX packets:204 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:16564 (16.1 Kb) TX bytes:16564 (16.1 Kb)

ppp0 Link encap:Point-to-Point Protocol

inet addr:80.237.74.95 P-t-P:80.237.74.2 Mask:255.255.255.255

UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1452 Metric:1

RX packets:84 errors:36 dropped:0 overruns:0 frame:0

TX packets:79 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:3

RX bytes:5326 (5.2 Kb) TX bytes:2786 (2.7 Kb)

—————————————————————————————————————————————————

Genie

а на самом сервере, который 10.0.3.1/10.0.1.xxx разрешена маршрутизация пакетов между интерфейсами?

что там за система, какие настройки сети?

anonymous

А нет ли еще 1го пользователя, который соединяется по pptp с 10.0.1.1 через 10.0.3.1?

Дело в том, что, насколько мне известно, чтобы роутер нормально разруливал такие ситуации, надо чтобы он разбирался во внутриностях pptp. Т.е. нужен соотв. модуль к netfilter.

Без этого все пакеты идут либо у 1му подключившемуся либо вообще не идут…

На практике с такой ситуацией я не сталкивался и объяснить почему происходит именно так я тоже не могу (ну не настолько хорошо разбираюсь в pptp), поэтому прошу относится как к слухам…

Если бы кто-то подтвердил/оправергнул эту мысль было бы здорово! …. Ну и может быть пояснил механизмы? ;)

Genie

хе=хе. повнимательнее надо читать

тут сказано же? даже не пингуется ;)

вот это и интересно — что именно настроено на сервере, который 10.0.3.1/10.0.1.xxx

может там, в нём и дело.

только всё как-то урывками изложено…

непонято, бессистемно.

вот бы чётко: что хочется. по полочкам.

что настроено: на концах соединения, на всех компах между этими концами.

какие трудности возникают.

а то как-то пытаться свести всё, что описано выше, в одну кучку как-то не получается. не стыкуется.

anonymous

Аналогичная проблема.

При использовании Debian 3.1 всё настроенное схожим образом работало.

В Mandrake 10.1 соединение устанавливается, но пинги не идут совсем или оказываются потерянными 40-100% пакетов.

Может в ядре дело?

В дебиане — 2.4.непомню :) , а в мандраке — 2.6.8.1…..

anonymous

Попробуй удалить маршрут default.

route del default

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.