nixp.ru v3.0

21 октября 2017,
суббота,
08:00:25 MSK

DevOps с компанией «Флант»
Ping_Win написал 10 августа 2005 года в 03:20 (662 просмотра) Ведет себя неопределенно; открыл 73 темы в форуме, оставил 102 комментария на сайте.

Здравствовать желаю!

Скомпилилисходники проги одной, после запуска выдаёт, что мол необходима библиотека libncurses.so.4. Но у меня стоит libncurses.so.5 и др.

Можно ли обойтись имеющимися библиотеками? Если нет, то откуда можно слить требуемую? Спасибо.

Sasha2

Ну попробу сперва так ln -s l<>.so.5 l<>.so.4

metal

Если первая цифра в версиях библиотек разная, то они не совместимы. Тебе надо поискать нужную библиотеку среди пакетов твоего дистрибутива.

Ping_Win

А каким образом это сделать?

Ведь не устанавливать же каждый пакет.

Есть какой-нибудь быстрый способ?

8084

ну смотря какой дистр, если rpm-based, то чеши на rpm.pbone.net, пиши там нужную тебе либу, и выбирай свой дистр, затем дави — ze4rch