nixp.ru v3.0

17 октября 2017,
вторник,
03:21:54 MSK

DevOps с компанией «Флант»
anonymous написал 24 апреля 2006 года в 02:41 (576 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Ставлю gtk-2.8.16, требует пакет glib>=glib-2.8.5, ставлю glib-2.10.2, запускаю установку gtk, а он мне выдаёт:

checking for GLIB — version >= 2.8.5…

* 'pkg-config --modversion glib-2.0\′ returned 2.10.2, but GLIB (2.6.4)

* was found! If pkg-config was correct, then it is best

* to remove the old version of GLib. You may also be able to fix the error

* by modifying your LD_LIBRARY_PATH enviroment variable, or by editing

* /etc/ld.so.conf. Make sure you have run ldconfig if that is

* required on your system.

* If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH

* to point to the correct configuration files

no

configure: error:

* GLIB 2.8.5 or better is required. The latest version of

* GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

Как удалить старый glib?

8084

С каким --prefix прогонял ./configure

Какой дистриб?

з.ы. видимо еще проблемы с инетом, раз повторяешься:D

fly4life
alterious
Ставлю gtk-2.8.16, требует пакет glib>=glib-2.8.5, ставлю glib-2.10.2, запускаю установку gtk, а он мне выдаёт:

checking for GLIB — version >= 2.8.5…

* 'pkg-config --modversion glib-2.0\′ returned 2.10.2, but GLIB (2.6.4)

* was found! If pkg-config was correct, then it is best

* to remove the old version of GLib. You may also be able to fix the error

* by modifying your LD_LIBRARY_PATH enviroment variable, or by editing

* /etc/ld.so.conf. Make sure you have run ldconfig if that is

* required on your system.

* If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH

* to point to the correct configuration files

no

configure: error:

* GLIB 2.8.5 or better is required. The latest version of

* GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

Как удалить старый glib?

А ты glib-devel новой версии установил?

rgo
* 'pkg-config --modversion glib-2.0\′ returned 2.10.2, but GLIB (2.6.4)

думается мне, что ты после `make install' в glib-2.10.2, забыл сказать ldconfig…