nixp.ru v3.0

29 мая 2017,
понедельник,
08:55:34 MSK

DevOps с компанией «Флант»
Ping_Win написал 7 мая 2006 года в 01:39 (732 просмотра) Ведет себя неопределенно; открыл 73 темы в форуме, оставил 102 комментария на сайте.

Здравствуйте!

Задача:

необходимо обеспечить win-машины локалки доступом в инет через VPN. Сервер на

Linux(Gentoo, kernel 2.6.9, поддержка PPTP,PPP вкомпилены в ядро).

Версия PPP-2.4.3

Проблема:

pptpd запускается, однако, когда win-client коннектится, сервер выдает ругательство о неизвестной ему опции:

unrecognized option 'require mschapv2\′

Подробности:

Конфиг pptpd.conf

speed 115200

option /etc/ppp/options.pptpd

debug

localip 192.168.0.1

remote 192.168.2-254

Конфиг options.pptpd

nobsdcomp

nodeflate

refuse-pap

refuse-chap

require-mschap

require-mschapv2

require-mppe

Файл chap-secrets:

ivanov * ivan 192.168.0.1

помогите пожалуйста.

Спасибо

Code Monkey

отключить на клиенте шифрование…

Genie
Проблема:

pptpd запускается, однако, когда win-client коннектится, сервер выдает ругательство о неизвестной ему опции:

unrecognized option 'require mschapv2\′

не знает оно у тебя про подобное шифрование (сервер, в смысле)

удали из конфига options.pptpd эту строчку

require-mschapv2

либо обнови pptpd до того, где оно есть.

ps: а вообще, тема для меня лично интересная, поэтому стукнись в аську.. :)

Genie

ну типа я поэкспериментил… ;)

что у тебя неправильного в конфигах (да-да!)

localip 192.168.0.1

remote 192.168.2-254

в remoteip ты, часом, не ошибся нигде?

иди-ка документацию читать!

сервер выдает ругательство о неизвестной ему опции:

unrecognized option 'require mschapv2\′

эта опция правильно пишется так:

require-mschapv2

ищи, где накривил :)

ну и тут:

Файл chap-secrets:

ivanov * ivan 192.168.0.1

ты пользователю ivanov даёшь адрес сервера? грустно ж будет ;)

что касается моих экспериментов…

$ apt-get install pptpd

и немного правки конфигов — и оно работает.

к ldap не прикрутилось… :(

radius ещё не пробовал…

хотя, если в /etc/ppp/chap-secrets правильно прописать имя клиента и его пароль, а в конфиге pptpd-options указать chapms-strip-domain — то можно на клиенте указать «использовать доменное имя и пароль»

Ping_Win

Блин, вот первые два случая это просто описка,

конечно 192.168.0.2-192.168.0.254

require-mschapv2

А вот с chapsecrets попробую

Ping_Win

А вот не хочет авторизоваться.(((

Поставил ядро 2.6.16

Включил PPP-MPPE compression в ядро

Поставил PPPd Версия 2.4.3

Поставил PPTPd Версия 1.2.3

Конфиг pptpd.conf содержит следующее:

option /etc/ppp/options.pptpd

debug

localip 192.168.0.21

remoteip 192.168.0.245

Файл /etc/ppp/options.pptpd:

refuse-pap

refuse-chap

refuse-mschap

require-mschap-v2

require-mppe-128

lock

nobsdcomp

nologfd

Файл chap-secrets:

«aaa» * «bbb» 192.168.0.245

Клиент — WinXp. Шифрование необязатедбное, mschapv2.

При установке соединения сервер ругается:

/usr/sbin/pppd: The remote system is required to authenticate itself

/usr/sbin/pppd: but I couldn’t find suitable secret (password) for it to use to do so.

/usr/sbin/pppd: (None of the available passwords would let it use an IP address)

Т.е. что-то я не так пишу в chap-secrets?

P.S. to Genie: если не трудно кинь свои конфиги пожалуйста

Спасибо.

Genie

держи…

$ cat /proc/version
Linux version 2.6.16.13-badram (genie@genie) (gcc version 3.3.5
 (Debian 1:3.3.5-13)) #2 SMP Thu May 4 00:52:20 NOVST 2006
$ pptpd --version
Poptop v1.2.1
$ pppd --version
pppd version 2.4.2

конфиг pptpd:

$ egrep -v '^ *(#|$)' /etc/pptpd.conf
option /etc/ppp/pptpd-options
localip 192.168.0.2
remoteip 192.168.1.1-254

конфиг ppp:

$ egrep -v '^ *(#|$)' /etc/ppp/pptpd-options
name pptpd
chapms-strip-domain
login
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
ms-dns 192.168.0.2
proxyarp
defaultroute
lock
nobsdcomp

ну и для авторизации…

$ sudo egrep -v '^ *(#|$)' /etc/ppp/chap-secrets
U53rN4m3   pptpd   S3crEt_P4s5w0rD      192.168.1.200

немного попозже возьмусь за raduis…

Ping_Win

Гутттт! Спасибо! Заработало!