nixp.ru v3.0

22 мая 2017,
понедельник,
22:23:53 MSK

DevOps с компанией «Флант»
Ping_Win написал 23 октября 2006 года в 22:20 (312 просмотра) Ведет себя неопределенно; открыл 73 темы в форуме, оставил 102 комментария на сайте.

Доброго времени!

Стал устанавливать софтинку, относящуюся к разряду к dockapps.

Она на стадии make ругаеттся что не найден gtk. Я напрямую указал ей куда смотреть подунув ей уже давно установленный gtk+-2.0, но тут вылезла добрая тыща ошибок.

Неужели gtk и gtk+ несовместимы??

Спасибо

fly4life

Во-первых, не совсем ясно, как ставишь (из исходников, из rpm-пакета или ещё как). Во-вторых, непонятно, что именно требуется твоей софтинке (тут лучше бы показать текст этих тыщ ошибок дословно).

DimkaS

А еще GTK бывает двух версий 1.2 и 2.0. Соответственно, и пакеты нужны разные.

Ping_Win

Я любитель всё поставить из исходников, соответственно, так и ставлю.

GTK+-2.0 поставил. Некоторый софт, например Mozilla, ругается, что нету мол

gtk-config. Поискал — действительно нет.

fly4life
Ping_Win
Я любитель всё поставить из исходников, соответственно, так и ставлю.

GTK+-2.0 поставил. Некоторый софт, например Mozilla, ругается, что нету мол

gtk-config. Поискал — действительно нет.

Потому что gtk-config находится в пакете gtk+-devel, да ещё и версии 1.х, а не 2.0.

Кстати, если ты «любитель всё поставить из исходников» (странно, что у тебя ALT Linux в таком случае ;)), то наличие пакетов '-devel' тебе, как минимум, желательно.

Ping_Win

Насколько я понимаю, Gtk-devel это пакет который содержит заголовочне файлы и прочее, но если я Gtk собирал из исходников, то все заголовки у меня есть.

Получается что Gtk1 и Gtk2 несовместимы?

fly4life
Ping_Win
Насколько я понимаю, Gtk-devel это пакет который содержит заголовочне файлы и прочее, но если я Gtk собирал из исходников, то все заголовки у меня есть.

Ты собирал gtk2, а gtk-config из gtk1.

Ping_Win
Получается что Gtk1 и Gtk2 несовместимы?

В плане, что программы разработанные с gtk1 не будут работать с gtk2? Ну да.