nixp.ru v3.0

25 мая 2017,
четверг,
23:09:53 MSK

DevOps с компанией «Флант»
parovoZZ написал 11 марта 2007 года в 21:26 (1943 просмотра) Ведет себя неопределенно; открыл 5 тем в форуме, оставил 15 комментариев на сайте.

Задумал поставить Оперу. Выдала

# rpm -ihv '/home/Andrey/Desktop/opera-9.10-20061214.6-shared-qt.i386-en.rpm'

ошибка: Неудовлетворенные зависимости:

libqt-mt.so.3 нужен для opera-9.10-20061214.6.i386

Погуглив, нашёл, что надо поставить что-то вроде qt3 ….Оказывается

linux:/home/Andrey # rpm -ihv '/media/FlightGear\ Live/suse/x86_64/qt3-3.3.7-12.x86_64.rpm'

Подготовка… ########################################### [100%]

пакет qt3-3.3.7-12 уже установлен

Может, думаю, нужно следующее

linux:/home/Andrey # rpm -ihv '/media/FlightGear\ Live/suse/x86_64/qt3-devel-3.3.7-12.x86_64.rpm'

ошибка: Неудовлетворенные зависимости:

cups-devel нужен для qt3-devel-3.3.7-12.x86_64

freetype2-devel нужен для qt3-devel-3.3.7-12.x86_64

libmng-devel нужен для qt3-devel-3.3.7-12.x86_64

libpng-devel нужен для qt3-devel-3.3.7-12.x86_64

libjpeg-devel нужен для qt3-devel-3.3.7-12.x86_64

c++_compiler нужен для qt3-devel-3.3.7-12.x86_64

xorg-x11-devel нужен для qt3-devel-3.3.7-12.x86_64

Mesa-devel нужен для qt3-devel-3.3.7-12.x86_64

Но на такое даже у меня терпения не хватит.

Гы. На маздае опера ставится двумя кликами мыши. И работает((.

Antern

rpm.pbone.net ?

иконкретнее

http://rpm.pbone.net/index.php3/stat/4/idpl/3702883/com/

А виндовз на то и виндовз , чтоб бешено кликать мышкой без понимания происходящего. Причем такие кликанья сопровождаются чайниковостью и глюковатостью — ФАКТ! мощно задвинул-таки 8-)

parovoZZ

Дык, там и искал. То, что там советуют, я поставил с диска. Результат — не видит

Antern

qt3-3.3.7-12.x86_64.rpm — дистриб

qt3-32bit-3.3.7-12.x86_64.rpm — то что качать надо

Для надежной защиты от магнитных аномалий советую снести пакет, что шел с дистрибом и воздвигнуть тот, что с сайто. Там четко написано, что предоставляет эту либу данный пакет.

(не следует производить излишние сексуальные надругательства над моском, намного проще сменить руки)

parovoZZ

А как различить? 32 бит? А у меня ж 64. Зачем мне 32?

Heavy

Тебе какая разница? А если посмотреть внимательно на название пакета, «x86_64» перед «rpm» говорит о чём нибудь?

ЗЫ: Читай литературу по Юниксу или по технике продавания арбузов

parovoZZ

усё, поставилось. Только значка нету. Как сделать?

По поводу удалить

linux:/home/Andrey # rpm -ev qt3-3.3.7-12

ошибка: Неудовлетворенные зависимости:

libqt-mt.so.3()(64bit) нужен для (установлен)CheckHardware-0.1-1017.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)qscintilla-1.65-40.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)sumf-0.2.4pre1-42.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)thinkeramik-style-3.2.1-57.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)chromium-0.9.12-1042.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)kdelibs3-3.5.5-45.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)python-qt-3.5.5-29.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)sax2-8.1-83.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)sax2-libsax-8.1-83.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)yast2-qt-2.14.3-5.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)opensuse-updater-0.4-31.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)sax2-gui-8.1-83.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)sax2-libsax-perl-8.1-83.x86_64

libqt-mt.so.3()(64bit) нужен для (установлен)yast2-control-center-2.14.1-6.x86_64

libqui.so.1()(64bit) нужен для (установлен)python-qt-3.5.5-29.x86_64

qt3 >= 3.3.7 нужен для (установлен)kdelibs3-3.5.5-45.x86_64

qt3 >= 3.3.5 нужен для (установлен)lsb-3.1-22.x86_64

qt3 нужен для (установлен)sax2-libsax-8.1-83.x86_64

qt3 нужен для (установлен)sax2-gui-8.1-83.x86_64

Antern

Естественно вызовет кучу неудовлетворенных зависимостей.. Это ж QT