nixp.ru v3.0

20 января 2017,
пятница,
14:53:37 MSK

DevOps с компанией «Флант»
xspirit написал 11 сентября 2007 года в 14:06 (295 просмотров) Ведет себя неопределенно; открыл 1 тему в форуме, оставил 8 комментариев на сайте.

Установил старенький CentOS 3.9 так как многого от него не нужно, вот. Попытался установить апач, а оно выдает ошыбку что компилятора ваапще нет. Как можно его установить?

[root@xplanet apr]#

checking for chosen layout… apr

checking for gcc… no

checking for cc… no

checking for cl.exe… no

configure: error: no acceptable C compiler found in $PATH

[root@xplanet apr]#

Дмитрий Шурупов

С помощью yum/rpm :-)

http://www.centos.org/docs/5/html/yum/sn-software-management-concepts.html

fly4life
xspirit
Установил старенький CentOS 3.9 так как многого от него не нужно, вот. Попытался установить апач, а оно выдает ошыбку что компилятора ваапще нет. Как можно его установить?

Из rpm-пакета. Как и сам apache, собственно.

xspirit

спасибо yum install gcc

xspirit

Ага блин рано обрадовался, все равно не работает

fly4life
xspirit
Ага блин рано обрадовался, все равно не работает

Что именно не работает?

xspirit

пишет не найдены дополнительные пакеты, куда ставить то ети пакеты?

fly4life
xspirit
пишет не найдены дополнительные пакеты, куда ставить то ети пакеты?

Какие пакеты? Лучше привести сообщение дословно.

xspirit

glibc-devel

cpp

glibc-headers

fly4life
xspirit
glibc-devel

cpp

glibc-headers

Эээ… команду для yum подсказать? ;)

xspirit

да, я скачал ети пакеты в какую папку их кидать что б оно автоматически установило? И команду желательно тоже

fly4life
xspirit
да, я скачал ети пакеты в какую папку их кидать что б оно автоматически установило? И команду желательно тоже

Эээ… а что мешает сделать так же, как и с gcc?

Ладно, раз уж всё равно скачал, то можно устанавливать с помощью rpm и пофиг из какого каталога. Подробности в 'man rpm’.

xspirit

DSA V3: NOKEY, key ID 1d1e034b а ет что :)

fly4life
xspirit
DSA V3: NOKEY, key ID 1d1e034b   а ет что :)

А это пакет «подписан» ключём, о котором твой rpm не в курсе. Тут либо надо найти и импортировать в базу rpm соответствующий ключ (тогда этого предупреждения не будет), либо просто забить (если ты доверяешь источнику, с которого слил пакет, и вообще не боишься руткитов с прочими паранойами) =).

xspirit

/var/cache/yum/base/packages/gcc-3.2.3-59.i386.rpm

Ошибка: Необходимо убедиться в том что вы имеете подходящий gpg ключ

[root@xplanet root]#

а ето что? осталось совсем немножко)))

fly4life
xspirit
/var/cache/yum/base/packages/gcc-3.2.3-59.i386.rpm

Ошибка: Необходимо убедиться в том что вы имеете подходящий gpg ключ

[root@xplanet root]#

а ето что? осталось совсем немножко)))

Дааа, поставь этот пакет тоже руками (в смысле, с помощью rpm).

xspirit

;) спс, мы его побороли!

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.