nixp.ru v3.0

26 мая 2017,
пятница,
08:43:17 MSK

DevOps с компанией «Флант»
Аватар пользователя ckjet
ckjet написал 18 января 2009 года в 22:32 (700 просмотров) Ведет себя как мужчина; открыл 44 темы в форуме, оставил 134 комментария на сайте.

У меня установлена мандрива, при попытке поставить .rpm выдает о том что не установлена glib 1.2.2 её тоже ставил через .rpm но ошибку как выдовало так и выдает.

ckjet

при ./configure glib если не с пакета пишет

ltconfig: you must specify a host type if you use `--no-verify'

Try `ltconfig --help' for more information.

configure: error: libtool configure failed

fly4life
ckjet
У меня установлена мандрива, при попытке поставить .rpm выдает о том что не установлена glib 1.2.2 её тоже ставил через .rpm но ошибку как выдовало так и выдает.

А rpm-паркеты откуда брал? От той ли они мандривы, что установлена у тебя? Оба от той? Да, rpmdrake разве не умеет устанавливать пакеты, вытягивая их с диска (ну, или Интернет-репозиитория) со всеми необходимыми зависимостями?

Кстати, в твоём случае полезно было бы выводить текст ошибки целиком (копи пастом из консоли).

ckjet

ошибка при ./configure glib

ltconfig: you must specify a host type if you use `--no-verify'

Try `ltconfig --help' for more information.

configure: error: libtool configure failed

Ошибка при установке плеера

checking for GLIB — version >= 1.2.2… no

* The glib-config script installed by GLIB could not be found

* If GLIB was installed in PREFIX, make sure PREFIX/bin is in

* your path, or set the GLIB_CONFIG environment variable to the

* full path to glib-config.

configure: error: * GLIB >= 1.2.2 not installed — please install first *

fly4life
ckjet
ошибка при ./configure glib

ltconfig: you must specify a host type if you use `--no-verify'

Try `ltconfig --help' for more information.

configure: error: libtool configure failed

Ошибка при установке плеера

checking for GLIB — version >= 1.2.2… no

* The glib-config script installed by GLIB could not be found

* If GLIB was installed in PREFIX, make sure PREFIX/bin is in

* your path, or set the GLIB_CONFIG environment variable to the

* full path to glib-config.

configure: error: * GLIB >= 1.2.2 not installed — please install first *

Я отвечал на пост, в котором рассказывалось об ошибке при установке rpm-пакета. Вот её-то и просил показать.

metal

Ох не знаю что за древность ты там решил поставить требующую glib-1.2. Но уставновка чего-то вроде libglib-1.*-devel должна помочь.

metal

А обратив внимание на тему :) xmms! Ты уверен что он тебе нужен?

fly4life
metal
Но уставновка чего-то вроде libglib-1.*-devel должна помочь.

Ну вот. Очередная установка rpm-based дистрибутива безнадёжно загажена… ;).

metal
fly4life
Ну вот. Очередная установка rpm-based дистрибутива безнадёжно загажена… ;).

Вообще он ставит src.rpm пакет, как я понимаю, не стоит так переживатью

fly4life
metal
Вообще он ставит src.rpm пакет, как я понимаю, не стоит так переживатью

src.rpm ставится не так (кстати, то ещё развлечение для новичка ;)).

metal
fly4life
src.rpm ставится не так (кстати, то ещё развлечение для новичка ;)).

Я думал это кусок, лога как раз от…как там? build-rpm что ли? Но если просто сборка из исходников, не факт что в этом дистрибутиве есть первый glib.

ckjet
metal
А обратив внимание на тему :) xmms! Ты уверен что он тебе нужен?

ну с кофеином слушать музыка вообще не фортово…

ckjet

я вообще решил не пользоваться рпм. Через консоль удобнее мне кажется

sky

Если уж хочется xmms, то стоит ставить beep media player, сам xmms уже давно покоится с миром…

Да и навернка beep media player присутствует в репозиториях…

ckjet

Вот ошибку с установки bmp

checking for glib-2.0 >= 2.4.0 gtk+-2.0 >= 2.4.0 gthread-2.0 pango… configure: error: Cannot find glib2/gtk2/pango

metal
ckjet
я вообще решил не пользоваться рпм. Через консоль удобнее мне кажется

rpm — это тоже через консоль, научись сначала им пользоваться.