nixp.ru v3.0

22 октября 2017,
воскресенье,
22:19:37 MSK

DevOps с компанией «Флант»
Аватар пользователя Максим
Максим написал 17 мая 2011 года в 13:47 (6096 просмотров) Ведет себя как мужчина; открыл 3 темы в форуме, оставил 10 комментариев на сайте.

Здравствуйте.

После появления Unity, моя душа не выдержала и я вернулся к KDE. И тут возникла проблема с интернетом. При настройке прокси не все программы автоматически начинают его использовать (в том числе Kopete, Firefox, aptitude, Skype). Часть из них можно, конечно, перенастроить вручную, но, во-первых, это долго, во-вторых, я так и не понял как это сделать для некоторых из этих программ (Kopete и aptitude, например).

Прошу помочь! Заранее спасибо.

dfghm
Максим

… После появления Unity, моя душа не выдержала и я вернулся к KDE…

А до перехода с KDE проблем с настройками прокси не было? )

Максим

Это было довольно давно, и прокси я не использовал. Да и сейчас стараюсь его избегать. С ним в любой ОС много возни.

spro0t

Я на работе вот так делал

export http_proxy=«user:pass@proxy:port/» — установить проксю

export http_proxy=»’ — вырубить проксю

засовывал строчку в bash.rc, но в браузере все равно прописывал проксю и все работало нормально.

Максим

К сожалению не помогло.

Может можете посоветовать что почитать по этой теме. Я, честно говоря, глубоко ниразу и не пытался копать. Видимо пора начать.

sampoerna

команды добавляются без проблем? что потом показывает есть набрать просто export?

тут вариантов то может быть полно, начиная о доступности машины с проксей, и заканчивая вводом адреса в настройках.

Вообще в кедах есть настройки глобальные для http прокси. В центре настроек (параметры системы) — есть Настройки Сети. там указывается адрес прокси.

Максим

При выполнении export последние две строчки выглядят так:

declare -x ftp_proxy=«10.37.59.2:3128/»

declare -x http_proxy=«10.37.59.2:3128/»

Может тут какие-то специальные обозначения для отсутствующих user:pass нужны?

А что касается кедовских настроек, то я их стразу и прописал. Но большинство программ их не видит.

sampoerna

что то меня сильно смущает на конце '/'

И попробуй в убунте так:

export http_proxy=«10.37.59.2:3128»

после чего собственно можно проверить каким нибудь links или lynx

Максим

Короче, нифига не помогет. Там и со слешами, и без них работать не хочет. Как есть, так есть.

Спасибо за помощь.

dfghm

Взято с кубунту.ру нод 5784

1. Step

kdesu kate /etc/apt/apt.conf.d/proxy
Acquire::http::Proxy "http://IP:PORT/";
Acquire::ftp::Proxy "http://IP:PORT/";
Acquire::::Proxy "true"; 


 

2. Step

System Settings — Network Settings — Proxy — Manually specify the proxy settings — Setup…

3. Step

kdesu kate ~/.bashrc
http_proxy=http://IP:PORT
export http_proxy
ftp_proxy=http://IP:PORT
export ftp_proxy


4. Step

kdesudo kate /etc/wgetrc


Находим

# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
http_proxy = http://IP:PORT/
ftp_proxy = http://IP:PORT/
# If you do not want to use proxy at all, set this to off. use_proxy = on


Отпишитесь с результатом

dfghm

5. UPD: Это началось с замены Konqueror в пользу Dolphine. Можно попробовать

#sudo apt-get install konqueror

Или с помощью synaptic. Он умеет работать с прокси.

Максим

Всё заработало! Спасибо!