nixp.ru v3.0

28 мая 2017,
воскресенье,
03:56:48 MSK

DevOps с компанией «Флант»
cod_zlovred написал 28 июня 2004 года в 12:03 (580 просмотров) Ведет себя неопределенно; открыл 3 темы в форуме, оставил 3 комментария на сайте.

Blackbox не запускается:

Ввожу startx

Запускается только Xinit

Жму Ctrl+Alt+BackSpace

AUDIT: Sat Jun 26 21:04:35 2004 : 545 XFree86 : client 1 rejected from local host

Xlib: connection to «:0.0» refused by server

Xlib: No protocol specified.

waiting for x server to begin accepting connections

AUDIT: Sat Jun 26 21:04:35 2004 : 545 XFree86 : client 1 rejected from local host

Xlib: connection to «:0.0» refused by server

Xlib: No protocol specified.

.

giving up.

xinit: unable to connect to x server

xinit: No such process(errno 3): Server error

xauth:(srgv):1: bad display name «:0» in «remove» command

xauth:(srgv):1: bad display name «:0» in «remove» command

Как это всё пофиксить?

anonymous

Создать в домашнем каталоге файл .xinitrc, в котором прописать что запускать. Типа start-blackbox (точно не помню что в blackbox запускается).

cod_zlovred

Файл xinitrc у меня существует в каталоге /usr/X11R6/lib/X11/xinitrc/

Причём всё нормально запускалось…

А сейчас я не могу понять характер этих ошибок.

Genie

Ключевые слова

Xlib: connection to «:0.0» refused by server

Xlib: No protocol specified.

Вопрос: как этого добились-то? :)

Стартует ли сам XFree86 ?

Можно ли, при запущенных голыми X-ами (командой X из консольного режима), запустить с явно указанной `DISPLAY=:0.0 xterm`?

Ну и немаловажный аспект: а действительно он на :0.0 запускается?

cod_zlovred

Вообще запускал так: xinit

Затем Blackbox и всё нормально работало…

С помощью «X» Xfree запускается…

«С явно указанной DISPLAY» Это как?

Пробовал запускать так: X :0.0 и X: 0

Запускается только Xfree!

Genie

X > /dev/null 2>&1 & (sleep 3; DISPLAY=:0.0 xterm)