nixp.ru v3.0

27 мая 2017,
суббота,
22:32:35 MSK

DevOps с компанией «Флант»
anonymous написал 23 октября 2004 года в 21:40 (344 просмотра) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

После перезагрузки ни стого ни с сего пропало dsp устройство (звука нет), как его вернуть?

Genie

«я тут хрень какую-то выпил, так разогнуться немогу, помогите, чего мне теперь уколоть надо?»

Uncle Theodore

Можно модуль какой-нить подгрузить, snd_pcm например.

Good Luck,

UT

anonymous

[root@localhost root]# lsmod

Module Size Used by

emu10k1 71844 0

ac97_codec 16844 1 emu10k1

snd_emu10k1 90120 0

snd_rawmidi 19492 1 snd_emu10k1

snd_pcm 82920 1 snd_emu10k1

snd_timer 20260 1 snd_pcm

snd_seq_device 6376 2 snd_emu10k1,snd_rawmidi

snd_ac97_codec 66276 1 snd_emu10k1

snd_page_alloc 8904 2 snd_emu10k1,snd_pcm

snd_util_mem 3200 1 snd_emu10k1

snd_hwdep 6884 1 snd_emu10k1

Два драйвера подгружены, а звука нет

anonymous

Я когда выключаеюсь, amarok играющим оставляю, он сам с системой вырубается

pol

«После перезагрузки ни стого ни с сего пропало dsp устройство (звука нет), как его вернуть?»

скажу по секрету ни с того ни с сего ничего не пропадает!?

у вас звук модулем!?

и вспомните (если можете) что вы делали

pol

прогани

modules-update

alsaconf

Genie

а amarok — ругается на отсутствие устройства?

или может банально, alsa-mixer надо запустить и каналы включить, громкость настроить…

pol

так я не доганяю:

модули подгруженны + devfs- но устройств нет, так не бывает!

anonymous

Все очень странно

1 раз запустил alsaconf дрова не подгрузились — звука нет, на kmix красненький крестик.

2 раз запустил alsaconf дрова загрузились, звук появился, но на kmix красненький крестик и при проверке звука в kcontol вылезает то же самое сообщение :

Sound server informational message:

Error while initializing the sound driver:

device /dev/dsp can’t be opened (No such file or directory)

The sound server will continue, using the null output device.

Думал перезагрузка поможет, после перезагрузки дрова не грузятся приходится опять два раза подряд запускать alsaconf

pol

устройства в папке есть!?

модули загруженны!?

ни кто с ними не работает!?

в /etc/modules.conf усё есть!?

если везде да — то должно работать — и перезагрузка не причём

anonymous

Вообщем сделал я чтобы дрова грузились, все, музыку послушать могу,но по прежнему появляется сообщение призагрузке kde:

Sound server informational message:

Error while initializing the sound driver:

device /dev/dsp can’t be opened (No such file or directory)

The sound server will continue, using the null output device.

И красный крестик на kmix, естественно kmix не работает, это мой самый любимый миксер,

как мне это dsp вернуть?

[root@localhost root]# lspcidrake -V | fgrep AUDIO

snd-emu10k1 : Creative Labs|SB Live! (audio) [MULTIMEDIA_AUDIO]

[root@localhost root]# grep sound-slot /etc/modules.conf

modules.conf ПУСТ

[root@localhost root]# chkconfig --list sound

sound 0:выкл 1:выкл 2:вкл 3:вкл 4:вкл 5:вкл 6:выкл

[root@localhost root]# chkconfig --list alsa

alsa 0:выкл 1:выкл 2:выкл 3:выкл 4:выкл 5:выкл 6:выкл

[root@localhost root]# fuser -v /dev/dsp

/dev/dsp: No such file or directory

[root@localhost root]# modprobe snd-emu10k1

И после того как я загрузил дрову, ЗВУКА по прежнему НЕТ

Genie

когда же научимся токлово ставить вопросы?

присутствует ли в систему devfs?

или не притуствует? тогда

# cd /dev/; ./MAKEDEV dsp

далее. /dev/dsp — это oss устройство. поэтому, чтобы заработало именно оно, необходимо подгружать модель oss эмуляции через alsa.

snd-pcm-oss которое. напару с snd-mixer-oss. — только тогда появится поддержка (эмуляция) oss.

anonymous

Я а}{уеваю, Захотел спать и решил все сделать утром, проснулся утром включил комп… и все работает, как будто ничего и не было…

pol

глюки однако!