nixp.ru v3.0

17 января 2017,
вторник,
10:03:39 MSK

DevOps с компанией «Флант»
anonymous написал 21 ноября 2004 года в 19:13 (266 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Ne mogu ustanovit XMMS iz ishodnicov pri ./configure vot takaya ohibka:

checking for GLIB — version >= 1.2.2… no

* The glib-config script installed by GLIB could not be found

* If GLIB was installed in PREFIX, make sure PREFIX/bin is in

* your path, or set the GLIB_CONFIG environment variable to the

* full path to glib-config.

configure: error: * GLIB >= 1.2.2 not installed — please install first *

Proboval ustanovit Glib (glib-1.2.10-15.i386.rpm) no v otvet poluchayu soobchenie o tom chto paket uje ustanovlen. Ustanovku distrebutiva delal polnuyu. (Fedora Core 3)

Zaranee Spasibo !!!

slice

Так он же требует glib 1.2.2, а у тебя версия старая стоит — 1.2.10 .Обнови библиотечку.

Genie

гхм.

а, интересно, почему для компиляции надо ставить саму glib, а не средства разработки, в частности, glib-devel??????

что-то я в этой жизни не понимаю…

glib-1.2.10-15.i386.rpm — это только .so.

что-то типа glib-1.2.10-15-devel.i386.rpm надо.

Genie
altruist
Так он же требует glib 1.2.2, а у тебя версия старая стоит — 1.2.10 .Обнови библиотечку.


оййй….. ой-ёй-ёй…..

старая… с каких это пор 1.2.2 стало больше 1.2.10 ????????????????

ну, разве что сравнивать как строки, да и то — под вопросом…

anonymous

Ustanovil iz ishodnikov glib-2.5.6 no rezultat tot je

Pomoemu emu nujen glib-config kotorogo ya v svoyey sisteme ne obnarujil

Kstate v distrebutive uje imeetsya XMMS 1.210 ustanovleniy vmeste s sistemoi

slice
Genie
оййй….. ой-ёй-ёй…..

старая… с каких это пор 1.2.2 стало больше 1.2.10 ????????????????

ну, разве что сравнивать как строки, да и то — под вопросом…

Мдааа бывает у меня иногда такое, когда подолгу за компутером сижу :) Аккумуляторы в блоке питания…… :)

fly4life
Ustanovil iz ishodnikov glib-2.5.6 no rezultat tot je

Гкхм… =)

Сказали же:

Genie
что-то типа glib-1.2.10-15-devel.i386.rpm надо.

Да, да, devel-пакеты, Kmouse, именно devel

slice

Народ, объясните мне почему со мной Dmitry Ivanov спорил, когда я доказывал, что для установки пакетов иногда необходимы devel-файлы?

fly4life
altruist
Народ, объясните мне почему со мной Dmitry Ivanov спорил, когда я доказывал, что для установки пакетов иногда необходимы devel-файлы?

А это как-то относится к обсуждаемой теме про установку XMMS ;)

Ну заведи новую тему, там и поговорим… Чего захламлять существующие, относящиеся к другому вопросу?

slice

извинтилияюсь за флейм :)

2 Kmouse

Чем тебя не устраивает версия xmms из дистра?

Vladimir

етот вопрос меня тоже заинтересовал :)

anonymous

Я пропатчил его что бы кодировки в плейлисте были нормальные.

А установить вот не могу ! :(

Не пойму зачем мне devel если я его из исходников поставил причём ошибок при сборке небыло :) ?

fly4life
Kmouse
Ne mogu ustanovit XMMS iz ishodnicov pri ./configure vot takaya ohibka:

checking for GLIB — version >= 1.2.2… no

* The glib-config script installed by GLIB could not be found

* If GLIB was installed in PREFIX, make sure PREFIX/bin is in

* your path, or set the GLIB_CONFIG environment variable to the

* full path to glib-config.

configure: error: * GLIB >= 1.2.2 not installed — please install first **

Это ты называешь «ошибок не было"? ;)

Dmitry Ivanov
altruist
Народ, объясните мне почему со мной Dmitry Ivanov спорил, когда я доказывал, что для установки пакетов иногда необходимы devel-файлы?

Я вижу, что он не пакет хочет установить, а собрать из исходников.

Dmitry Ivanov
Kmouse
Я пропатчил его что бы кодировки в плейлисте были нормальные.

А установить вот не могу ! :(

Не пойму зачем мне devel если я его из исходников поставил причём ошибок при сборке небыло :) ?

Значит configure не видит glib-config. Или опознать не может.

Вообще, научитеь читать то, что выдает скрипт:

«set the GLIB_CONFIG environment variable to the full path to glib-config.»

И еще — установить вы установили, но вы уверены, что поставились не только сами либы и еще и девелоперская обвязка к ним?

Да, еще неплохо бы убедиться, что glib-2.5.6 совместима с glib-1.2.10, прежде чем ее ставить. особенно из сорцов.

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.