nixp.ru v3.0

21 января 2017,
суббота,
16:25:09 MSK

DevOps с компанией «Флант»
anonymous написал 6 января 2004 года в 23:38 (581 просмотр) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Поставил я себе RedHat 9.0 и столкнулся с такой проблемой:

При загрузке выдает «Инициализируется контролллер ehci-hcd» и че-то еще про USB, а потом виснет!!!!!! (А у меня как раз USB клава и мышь в разных дырках). Ну я недолго думая отрубаю клаву с мышкой и подключаю обычные ps/2. Все путем — грузится. Причем при установке он ругался так же. Пришлось устанавливать с ps/2 девайсами в надежде, что после установки он все-таки найдет USB.

Но увы……

Че делать, народ???

DarkWizard

Попробуй биос — потому что е меня RedHat 9.0 без проблем опознал и крысу и клаву USB’шную…

anonymous

В биосе USB включен на 6 дырок. All devices тоже стоит….

Помогите.

decvar

а ты уверен что он правельные драйверы использует?

ehci-hcd??? это вроде какой-то спецовый усб…

должны быть такие:

usb-uhci

usbcore

попробуй прогнать kudzu или сам поправь /etc/modules.conf

добавь вместо товего усб

alias usb-controller usb-uhci

svnk

usb-uhci подгружается.

А с kudzu ситуация обстоит так:

Выключаем поддержку USB на матери — она это видит и есессено паникует типа че-то изменилось, предлагает удалить настройки по девайсам. Удаляю. Включаю снова USB в биосе ну она есесено говорит, типа что-то нашла. ПРИЧЕМ когда говорит, что она что-то нашла, клава работает. Тоесть я могу нажать кнопку «настроить девайс».

Ок, типа настроила, все сделала…..Грузимся…..Просто командная страка, хотя стоит автостарт X-ов. Я есесено ничего пока не меняю (типа глюк)….Перезагружаюсь…..И в итоге тоже самое снова…..

Извините, если логика действий у меня не правильная. Я просто новенький совсем в *nixax…

decvar

ладно, к чертям этого kudzu…

мое ИМХО драйвер тебе нужен именно usb-uhci, а не ehci-hcd как кудзу думает…

делаем след. действия.

1. нужно попасть в консоль с работаюшей клавой…не важно усб или нет.

2. команда (то рута)

setup

там system services -> снимает галку с kudzu и еще парочки не нужных

3. в файле /etc/modules.conf

смотрим что там на счет усб этот кудзу написал

будет что-то типа

alias bla-bla-bla ehci-hcd

все это коментим и меняем на

alias usb-controller usb-uhci

4. в файле /etc/X11/XF86Config

есть секция относительно мыши

делаем из них следуюшее

Section «InputDevice»

Identifier «Mouse0»

Driver «mouse»

Option «Protocol» «IMPS/2»

Option «Device» «/dev/input/mice»

Option «ZAxisMapping» «4 5»

Option «Emulate3Buttons» «no»

EndSection

5. даем команду

dmesg (от рута все)

и смотрим какие устройства ядро прицепило…

вывод команды в студию

svnk

Завелось это чучело.

Все заработало, после того как я выключил поддержку в биосе для доса мыши с клавой и все заработало (саму поддержку USB конечно оставил на все 6 каналов). Но тогда клава начинает работать только после того как шапка отдетектит USB а происходит это гораздо позде, чем загружается GRUB и приглашение интерактивного сетапа. Опять же……Мелочь, а неудобно. Какой-то конфликт между биосом и никсами…..

Есть варианты решения?

Кстати, спасибо тебе за помощь. ОООООгромное такое человеческое спасибо! :)

decvar

Заменить GRUB на Acronis OS Selector. Он единственный (мне известный) поддерживает усб переферию(больше чем Граб) на загрузке. Идес АСПЛинуксом Стандарт и выше. Вроде в Инете видел.

ЗЫ

У меня усб клава виделся Грубом при загрузке без проблем.  А мыша нет….ну и х с ней. Клава BTC.

и еще, а БИОС обновить не пробовал?

MadMax

Всем привет!

У меня модем ADSL USB, пож. помогите его настроить в Red Hat 9.0. Нужен ли для него драйвер?

decvar

А по конкретнее про модем!!!

ЗЫ

ЕСТЬ СПИСОК СОВМЕСТИМОГО ОБОРУДОВАНИЯ!

СМ. WWW.REDHAT.COM!!!!!!!!!!!!!!!!!!!!!!!!!!!

MadMax

ОК, все по-порядку:

USB Modem ALE 130 чипсет GlobespanVirata

OS: Linux Red Hat 9.0, кернель 2.4.20

Что я сделал чтобы долбаный модем заработал:

0. Прочитал как писать FAQ.

1. сгрузил и инсталлировал eci adsl драйвер с сайта www.flashtux.org — хор. сайт, советую.

удалил dabusb.

запустил eciconf.sh, установил VPI = 8, VCI = 48 (как в Windows), username, password,

выбрал ECI B(Hi) focus модем, VCM_RFC2364 (PPPoATM NULL Encapsulation в Windows), provider и т.д.,

change synch01.bin

startmodem | tee log.txt -> modem not found

(пробовал со всеми модемами)

2. отключил modem, запустил probe_device.sh -> VID1 = VID2 = 1690; PID1 = PID2 = 0211

(как и в Windows->System Information только там один VID и PID).

запустил eciconf.sh, выбрал Other modem, установил VID1/2, PID1/2,

change synch01.bin

startmodem | tee log.txt -> ECI load 2: failed

3. запустил все synchXX.bin файлы с сайта www.flashtux.org. скриптом probe_synch.sh -> ECI load 2: failed

4. сгрузил USB sniffer, сделал лог файл с родным драйвером модема, т.к. модем не работает в Windows

с драйвером ECI, даже если заменить VID/PID в файлах inf перед инсталляцией (как они советуют).

назад в Linux:

запустил eci_vendor_device.pl usbsnoop.log, сделал bin file, поместил его в директорию /etc/eciadsl,

запустил eciconf.sh, выбрал my_synch.bin

запустил startmodem и получил то же самое: ECI load 2: failed.

/////////////// startmodem message ////////////////////

setting up USB support (1/5)..

loading firmware (2/5)..

ECI load 1: failed

ECI load 1: success

firmware loaded successfully

setting up modem (3/5)..

ECI load 2:failed

failed to get synchronization

///////////////////////////////////////////////////////

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.