nixp.ru v3.0

23 января 2017,
понедельник,
07:41:38 MSK

DevOps с компанией «Флант»
anonymous написал 29 июля 2004 года в 22:57 (349 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Suse 9.1 Pro. Нашел вот такой вариант включения этого модема с драйверами Smart Link Soft Modem for Linux version 2.9.8 в Readme:

ALSA mode

=========

ALSA has the built-in modem drivers included in 'alsa-driver' >= 1.0.2

and in Linux kernel >= 2.6.5. Currently there is 'intel8×0m' (snd-intel8×0m)

modem driver, which supports ICH based AC97 modems (MC97).

1. Configure your kernel and enable ALSA and ICH based modem support

( 'Device Drivers' -> 'Sound' -> 'Advanced Linux Sound Architecture' ->

'PCI devices' -> 'Intel i8×0/MX440; AMD768/8111 modems' ) .

2. Build and install kernel and modules as usual (make , make modules_install,

etc.). ICH modem driver modem module name is ’snd-intel8×0m'

(if was configured as module).

3. Build application ’slmodemd' with ALSA support. For this in

slmodem-2.9.x dir:

$ cd modem

$ make SUPPORT_ALSA=1

This will build ’slmodemd' with ALSA support. If compilation is failed

review Makefile (near ALSA_SUPPORT condition) and define right library

and/or CFLAGS

4. Use option '—alsa' when running ’slmodemd' and ALSA conventional

device name (’hw:0\′ or 'hw:1\′ for instance). If modem support in

the kernel was enabled as module module ’snd-intel8×0m' should be loaded.

When using ALSA modem driver you don’t need to load other modules (’slamr’).

Ядро — 2.6.5. Проверил — имеется уже готовый модуль snd-intel8×0m. Загрузил по insmod .

Скомпилировал slmodemd — успешно. Но когда его запускаю

slmodemd —alsa вылезает

такая ошибка: error: alsa setup: cannot open playback device 'hw:1\′: No such deviceerror: cannot setup device `hw:1\′. Подскажите как с этим бороться.

Uncle Theodore

А модуль snd-intel8×0m загружен? Может, нужно device hw:0 указать для модема?

Good Luck,

UT

anonymous

А прав хватает? Очень похоже что нет прав на этот девайс.

anonymous

Удалось наконец его запустить. Оказалось что мудрить с ALSA не нужно. Нужно просто запустить /usr/bin/slmodemd и оставить его запущенным, я по незнанию вырубал его по Сtrl-C. Теперь осталось настроить загружаться его сразу при загрузке системы. Использовал драйверы slmodem 2.9.9. Между прочим в Suse модуль slamr есть уже готовый и компилировать его не нужно.

anonymous

И насколько помогает компиляция и запуск без —alsa?

Дело в том, что у меня в ноутбуке модем 8086:2486 — под который, по идее, тоже подходит смартлинковский драйвер. Однако в режиме без ALSA он вроде бы как работает, однако корректно дозваниваться и тем более соединяться ни в какую не желает (на номер, на который под виндой связывается на 52000-53000 из-под линуха только дозванивается, потом долго «договаривается» со включенным звуком, и в конце концов выдаёт No Carrier. На другой номер удалось один раз подключиться на скорости 33000, через полминуты связь также разорвалась (из-под винды, опять же, на этот номер устойчиво держит 50,6к)).

В рекомендации scanmodem сказано, что 8086:2486 подключается вместе alsa, однако выдаёт всё ту же ошибку -

cannot open playback device 'modem:1\′

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.