nixp.ru v3.0

18 октября 2017,
среда,
01:14:36 MSK

DevOps с компанией «Флант»
anonymous написал 5 декабря 2004 года в 15:53 (416 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Я пробовал ставить дрова 6106 они сами не находят исходников ядра,

когда прописываю вручную начинает ставить но предупреждает: в вашем ядре

включена поддержка rivafb , драйвера nvidia конфликтуют с ней. после этого

инсталляция доходит до 100% и говорить nvidia kernel build failed.

Пробовал ставить дрова 6111, они не матерятся вообще, нормально инсталятся,

в конце говорит запусти sax2… настрвиваю, при тестировании с отключенным

3D запускается и работает 2-3 секунды, после чего вылетает. Со включеным 3D

просто мелькает экран и сразу-же вылетает с ошибкой

*******ABORTING*******

screens found, but none configuration have a usable configuration.

вот лог:

X Window System Version 6.8.1

X Protocol Version 11, Revision 0, Release 6.8.1

Build Operating System: SuSE Linux [ELF] SuSE

Current Operating System: Linux alex 2.6.8-24-default #1 Wed Oct 6 09:16:23 UTC 2004 i686

Module Loader present

Markers: (--) probed, (**) from config file, (==) default setting,

        (++) from command line, (!!) notice, (II) informational,

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: «/var/log/Xorg.0.log», Time: Sun Dec  5 00:48:08 2004

(==) Using config file: «/etc/X11/xorg.conf»

(==) ServerLayout «Simple Layout»

(**) |-->Screen «Screen 1» (0)

(**) |   |-->Monitor «My Monitor»

(**) |   |-->Device «** NVIDIA (generic)                   [nv]»

(**) |-->Input Device «Mouse1»

(**) |-->Input Device «Keyboard1»

(**) FontPath set to «/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/CID,/usr/X11R6/lib/X11/fonts/75dpi,/usr/X11R6/lib/X11/fonts/local,/usr/local/share/fonts,/usr/X11R6/lib/X11/fonts,/usr/X11R6/lib/X11/fonts/cyrillic,/usr/X11R6/lib/X11/fonts/truetype,/usr/X11R6/lib/X11/fonts/uni,/usr/X11R6/lib/X11/fonts/URW,/usr/local/share/fonts/truetype»

(**) RgbPath set to «/usr/X11R6/lib/X11/rgb»

(==) ModulePath set to «/usr/X11R6/lib/modules»

(WW) Open APM failed (/dev/apm_bios) (No such device)

(II) Module ABI versions:

        X.Org ANSI C Emulation: 0.2

        X.Org Video Driver: 0.7

        X.Org XInput driver : 0.4

        X.Org Server Extension : 0.2

        X.Org Font Renderer : 0.4

(II) Loader running on linux

(II) LoadModule: «bitmap»

(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a

(II) Module bitmap: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        Module class: X.Org Font Renderer

        ABI class: X.Org Font Renderer, version 0.4

(II) Loading font Bitmap

(II) LoadModule: «pcidata»

(II) Loading /usr/X11R6/lib/modules/libpcidata.a

(II) Module pcidata: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        ABI class: X.Org Video Driver, version 0.7

(--) using VT number 7

. . . . . .. . .. . . ..

(II) PCI-to-ISA bridge:

(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0×0008 (VGA_EN is set)

(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400] rev 178, Mem @ 0xec000000/24, 0xe0000000/27

. . . .

(II) LoadModule: «dbe»

(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a

(II) Module dbe: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        Module class: X.Org Server Extension

        ABI class: X.Org Server Extension, version 0.2

(II) Loading extension DOUBLE-BUFFER

(II) LoadModule: «extmod»

(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a

(II) Module extmod: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        Module class: X.Org Server Extension

        ABI class: X.Org Server Extension, version 0.2

(II) Loading extension SHAPE

(II) Loading extension MIT-SUNDRY-NONSTANDARD

(II) Loading extension BIG-REQUESTS

(II) Loading extension SYNC

(II) Loading extension MIT-SCREEN-SAVER

(II) Loading extension XC-MISC

(II) Loading extension XFree86-VidModeExtension

(II) Loading extension XFree86-Misc

(II) Loading extension DPMS

(II) Loading extension TOG-CUP

(II) Loading extension Extended-Visual-Information

(II) Loading extension XVideo

(II) Loading extension XVideo-MotionCompensation

(II) Loading extension X-Resource

(II) LoadModule: «type1»

(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a

(II) Module type1: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.2

        Module class: X.Org Font Renderer

        ABI class: X.Org Font Renderer, version 0.4

(II) Loading font Type1

(II) Loading font CID

(II) LoadModule: «freetype»

(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so

(II) Module freetype: vendor=«X.Org Foundation & the After X-TT Project»

        compiled for 6.8.1, module version = 2.1.0

        Module class: X.Org Font Renderer

        ABI class: X.Org Font Renderer, version 0.4

(II) Loading font FreeType

(II) LoadModule: «nvidia»

(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o

(II) Module nvidia: vendor=«NVIDIA Corporation»

        compiled for 4.0.2, module version = 1.0.6111

        Module class: XFree86 Video Driver

(II) LoadModule: «mouse»

(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o

(II) Module mouse: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        Module class: X.Org XInput Driver

        ABI class: X.Org XInput driver, version 0.4

(II) LoadModule: «kbd»

(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.o

(II) Module kbd: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 1.0.0

        Module class: X.Org XInput Driver

        ABI class: X.Org XInput driver, version 0.4

(II) NVIDIA X Driver  1.0-6111  Tue Jul 27 07:56:22 PDT 2004

(II) NVIDIA Unified Driver for all NVIDIA GPUs

(II) Primary Device is: PCI 01:00:0

(--) Assigning device section with no busID to primary device

(--) Chipset NVIDIA GPU found

……………

(II) Setting vga for screen 0.

(II) Loading sub module «vgahw»

(II) LoadModule: «vgahw»

(II) Loading /usr/X11R6/lib/modules/libvgahw.a

(II) Module vgahw: vendor=«X.Org Foundation»

        compiled for 6.8.1, module version = 0.1.0

        ABI class: X.Org Video Driver, version 0.7

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32

(==) NVIDIA(0): RGB weight 888

(==) NVIDIA(0): Default visual is TrueColor

(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)

(--) NVIDIA(0): Linear framebuffer at 0xE0000000

(--) NVIDIA(0): MMIO registers at 0xEC000000

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!

(EE) NVIDIA(0):  * Aborting *

(II) UnloadModule: «nvidia»

(II) UnloadModule: «vgahw»

(II) Unloading /usr/X11R6/lib/modules/libvgahw.a

(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:

no screens found

Please consult the The X.Org Foundation support

         at http://wiki.X.Org

 for help.

Please also check the log file at «/var/log/Xorg.0.log» for additional information.

anonymous

Все уже поставил

Master
BlezAlex
Все уже поставил

Ну а в чем же грабли были?

Genie
Ну а в чем же грабли были?

Ну, если подумать несколько телепатически, проблема была в том. что был включён rivafb на стадии загрузки системы, и поэтому модуль не мог загрузиться:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!