nixp.ru v3.0

19 октября 2017,
четверг,
01:22:39 MSK

DevOps с компанией «Флант»
v0devil написал 8 декабря 2004 года в 17:57 (320 просмотров) Ведет себя как мужчина; открыл 27 тем в форуме, оставил 60 комментариев на сайте.

Не только в третьей федоре, но раньше справлялся..Ставлю я дрова nvidia, а он мне говорит что сорсы кернела не установлены, хотя они стоят.. и не хочет собирать дрова. При указание --kernel-name=«2.6.9» дрова собирает, но nvidia.ko не подгружает, ссылась на ошибку… Чё делать ? :)

Genie

телепаты, которые в бессрочном отпуску, всё же докладывают, что драйвера версии 6111 и ядро скомпилировано с опцией «Use 4Kb for kernel stacks instead of 8Kb»

кроме того, они намекнули и на вариант проблемы с экспортом каких-то символов в ядре.

и советуют обновить драйвер.

v0devil

всё решается патчем:

— NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv.c 2004-08-31 22:52:17.000000000 +0100

+++ NVIDIA-Linux-x86-1.0-6111-pkg1-new/usr/src/nv/nv.c 2004-09-20 02:49:42.399538232 +0100

@@ -19,6 +19,10 @@

MODULE_ALIAS_CHARDEV_MAJOR(NV_MAJOR_DEVICE_NUMBER);

#endif

+#ifndef __VMALLOC_RESERVE

+unsigned int __VMALLOC_RESERVE;

+#endif

+

/*

* our global state; one per device

*/

и установкой на nv.c… patch -i < patch.patch

Genie

а поискать по форуму по словам «2.6.9 nvidia» и найти:

http://www.nixp.ru/cgi-bin/forum/YaBB.pl?board=faq;action=display;num=1098030565

а?

v0devil

Такссс… А почему модули при загрузке не загружаются? Хотя все алиазы в modprobe.conf прописаны :-/ . то же самое с модемом… :(

fly4life
v0devil
Такссс… А почему модули при загрузке не загружаются? Хотя все алиазы в modprobe.conf прописаны :-/ . то же самое с модемом… :(

http://www.nixp.ru/cgi-bin/forum/YaBB.pl?board=flame;action=display;num=1101072438

v0devil

действительно искать не умею, спасиб, щаз попробую :)

v0devil

Ну эт ладно, модуль подгружается… после загрузки… А ведь тот же bootsplash не работает… зависает на «проверке ядра», при загрузке… т.е. он не знает, чё за драйвер nvidia …

fly4life
v0devil
Ну эт ладно, модуль подгружается… после загрузки… А ведь тот же bootsplash не работает… зависает на «проверке ядра», при загрузке… т.е. он не знает, чё за драйвер nvidia …

Вероятно, твой bootsplash загружается раньше, чем успевает подгрузиться драйвер видеокарты. Чего тебе сделать с этим — не знаю ;). Могу предложить отказаться от splash’а ;).

v0devil

Ну так я и говрю, что быстрее драйвера… блин, тупой дистриб, хотя как всегда /dev/hands… Почему во 2 ведоре с загрузкой модулей было всё OK, а в третьей такая фигня… ?

Genie

Хе-хе-хе… bootsplash…

Ой…

для сплеша надо frame buffer, а никак не дрова от nVidia, которые предоставляют ускорение в XFree86/XOrg.

только грабли тут такие: vesafb не всё позволяет, а rivafb конфликтует с дровами от nVidia.

Могу предложить отказаться от splash’а ;).


видимо, самое правильное решение ;) вместе с выкидыванием fb нафик.

Консоль, текстовая, нужна только для загрузки и настройки Иксов/сети. Всё..

PS: а глюк, в первую очередь, вероятнее всего, в /dev/brains. :D

v0devil

В /dev/brains это у тебя проблемы, умник… Походу на nixp.ru все такие крутые, что ничего спросить нельзя.. А если спросить, так получив 10 оскорблений … преимущественно от «очень крутого» genie…

Genie
что ничего спросить нельзя..


можно спрашивать. и нужно, если есть проблема.

правда, нужно так же и показывать, что есть стремление решить самому эту проблему, а не простое «ну разжуйте, мне, тупому, да так, чтобы я только по шагам сдела, по написанному — а оно и заработало».

а ведь направлений на то, чтобы изучать что именно не так, давалось несколько. и в какую сторону смотреть.

но для v0devil это оказывается оскорблениями, и преимущественно от меня.

очень мило, буду знать.

ну а чтобы кое-кому не влипать в такие ситуации и не оскорбляться по пустякам, почитай, v0devil, «Как правильно задавать вопросы».

sky
Genie
Хе-хе-хе… bootsplash…

Ой…

для сплеша надо frame buffer, а никак не дрова от nVidia, которые предоставляют ускорение в XFree86/XOrg.

только грабли тут такие: vesafb не всё позволяет, а rivafb конфликтует с дровами от nVidia.

видимо, самое правильное решение ;) вместе с выкидыванием fb нафик.

Консоль, текстовая, нужна только для загрузки и настройки Иксов/сети. Всё..

PS: а глюк, в первую очередь, вероятнее всего, в /dev/brains. :D

vesafb позволяет использовать bootsplash, вот только при 16-ти битном цвете…. это уже в сторону grub (vga=791 etc)

anonymous

установил дрова nvidia на FC3 !!!! ёёё

загрузил telinit :3:

# sh NVIDIA-Linux-x86-1.0-6629-pkg1.run

потом как на http://www.nvnews.net/vbulletin/showthread.php?t=40622

# modprobe nvidia

# cp -a /dev/nvidia* /etc/udev/devices/

telinit:5:

править /etc/X11/xorg.conf

reboot

и ёоу дрова грузанулись