nixp.ru v3.0

20 января 2017,
пятница,
18:56:39 MSK

DevOps с компанией «Флант»
v0devil написал 8 мая 2005 года в 18:00 (253 просмотра) Ведет себя как мужчина; открыл 27 тем в форуме, оставил 60 комментариев на сайте.

У меня Panasonic Lumix DMC-LS1, подключаю.. и ни одна gui-прога(типа digital camera tool) не распознаёт.. вот dmesg выводит :

usb 2-1: new full speed USB device using address 3

scsi1 : SCSI emulation for USB Mass Storage devices

Vendor: MATSHITA Model: DMC-LS1 Rev: 0100

Type: Direct-Access ANSI SCSI revision: 02

SCSI device sda: 1002497 512-byte hdwr sectors (513 MB)

sda: Write Protect is off

sda: Mode Sense: 04 00 00 00

sda: assuming drive cache: write through

sda:

может как-нить mount`ом? ядро естесственно собрано с поддержкой цифровух..

Genie

попробуй примонтировать как обычную флешку. должно получиться, так как

scsi1 : SCSI emulation for USB Mass Storage devices

проверь сперва fdisk-ом fdisk -l /dev/sda есть ли там разделы, если есть — монтируй sda1, если нет — пробуй примонтировать sda

v0devil

попробовал fdisk и… ничего консоль как бы сказать «зависает». При монтировании /dev/sda происходит то же самое :( . А вообще в /dev/ только sda есть ..

Genie

гхм.. плохо….

она цепляется модулем usb-storage, и потому недоступна другим для использования..

надо искать, как запретить её «прихватизацию» этим модулем.

ну и вообще, поквыряй гугль://"Panasonic Lumix DMC-LS1"+linux

v0devil

да молчит гугль про мою камеру.. посмотрел доки про цифровухи.. всё так и делаю , но у них sda1 монтируется, а у меня нет, висит… Что там надо запретить? прихватизацию? :))

Genie

ну, тогда не совсем даже и понятно, если она видится как флешка, но не работает так. к тому же, мой gphoto2 о такой не в курсе:

$ gphoto2 —list-cameras|grep -i Panasonic

«Panasonic Coolshot KXL-600A»

«Panasonic Coolshot KXL-601A»

«Panasonic Coolshot NV-DCF5E»

«Panasonic DC1000»

«Panasonic DC1580»

«Panasonic PV-L691»

«Panasonic PV-L859»

так что — в гугль, искать. (я из дома сам в гугль почти не шастаю, накладно это)

v0devil

и мой.. мне теперь что, ждать пока добавят %) почему у меня /dev/sda зависает ..?

Dmitry Ivanov
v0devil
попробовал fdisk и… ничего консоль как бы сказать «зависает». При монтировании /dev/sda происходит то же самое :( . А вообще в /dev/ только sda есть ..

Чисто для размышления:

idv@nest:~/Mail$ ls /dev/ | grep sda

sda

sda1

sda10

sda11

sda12

sda13

sda14

sda15

sda2

sda3

sda4

sda5

sda6

sda7

sda8

sda9

idv@nest:~/Mail$

v0devil

да всё норм, ядро было плохо собрано.. :(

Genie
да всё норм, ядро было плохо собрано.. :(

ну, рассказывай, что именно исправил.

где что подкрутил?

v0devil

да похоже по дефолту в asp ядро было собрано без usb mass storage и что-то ещё с scsi плохо было. Пара галочек всё исправило ;-) /dev/sda1 появляется , всё норм..

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.