nixp.ru v3.0

29 мая 2017,
понедельник,
16:09:52 MSK

DevOps с компанией «Флант»
anonymous написал 17 декабря 2005 года в 02:14 (227 просмотров) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Ядро 2.6.15 (но пробовал и на 2.4.31)

Slackware 10.2

Последний драйвер для видяхи NVIDIA-Linux-x86-1.0-8174-pkg1.run.txt (но пробовал и с Vesa-драйвером — проблема остаётся)

Сама видяха — Leadtek Winfast GeForce FX 5700

В общем, у меня отображается графика не так, как нужно.

Например, на картинке рабочего стола чёрные, не чередующиеся полосы. Должны же на ней изображены быть едва заметные, ровные, чередующие полосы.Причём, эту картинку загружал и в просмоторщики — там тоже самое. В винде картинка выглядит нормально.И так со всей графикой: какие-то элементы сильно выделяются, а часть из них наоборот отсутствует.Эксперементировал с xorg.conf — оказалось, что всё нормально отображается на разрешении 1152х840. Но при этом разрешении частота обновления — 75Гц, что меня не устраивает.

Можно ли убрать эту проблему для разрешения 1024х768?

Genie
всё нормально отображается на разрешении 1152х840. Но при этом разрешении частота обновления — 75Гц, что меня не устраивает.

может настроить правильно ModeLine дл яэтого режима? ;)

что изменяется при переключении битности вывода? на всех ли это так — 8, 16, 24(32)?

может, кстати, это быть и от того, что (не) включен какой-нибудь модуль в конфиге xfree/xorg.

и что с предыдущей версией драйвера? работает нормально при тех же настройках? (хотя, может на новом ядре, которое 2.6.15, и не работать вообще..)

anonymous

В общем, у меня вот эта тема для WM — http://download.freshmeat.net/screenshots/27833.jpg

Видишь на фоне чёрные горизонтальные полосы?

Так вот у меня они, во-первых, не чередующиеся (т.е не подряд идут, а по четыре, а пятой полосы вообще нет). Во-вторых, эти полосы присутствует даже в белой части фона, где их не должно быть.

Да, во всех режимах, которые я пробовал (8, 16, 24) такая фигня..

>> «может, кстати, это быть и от того, что (не) включен какой-нибудь модуль в конфиге xfree/xorg.

и что с предыдущей версией драйвера? работает нормально при тех же настройках? (хотя, может на новом ядре, которое 2.6.15, и не работать вообще..) »

Ну я пробовал ещё дрова Nvidia 7181 (или что-то типа этого), а также NV и даже VESA — та же проблема!

Насчёт модуля — может.. Но я не знаю, что за модуль такой может быть.. =(

Да, и ещё, помню, что в Mandrake всё было ОК.

Sasha2

Я вот лично никаких полос ни в WIndows, ни в Линукс не вижу на той картинке, что ты привел.

А у меня nVidia работает отлично.

anonymous

Я вот, что только заметил!!!

Такая фигня возникает только в WindowMaker’е, в других оконных менеджерах такого нет.. Это о чём-нибудь говорит?

Sasha2

Говорит, о том, что ты не очень внимательный.

rgo
cybermind
Это о чём-нибудь говорит?

говорит наверное… Только о чём?

может быть, о том что WindowMaker не умеет растягивать картинку? Ну точнее интерполирует цвета точек при растяжении немного иначе чем остальные. Попробуй её в gimp’е привести к нужному разрешению.

anonymous

Ну не знаю.. Просто до Слаки у меня стоял Мандрэйк, и в ней WindowMaker всё нормально отображал.

anonymous

Всё! Проблема решена! =)

WindowMaker и вправду не умеет масштабировать изображения.

А всё хорошо работало на разрешении 1152х864, потому что у самого фона такое разрешение. Ну я его GIMP’ом уменьшил до 1024х768, и теперь всё отлично работает! =)

anonymous

Только ещё один вопрос: можно ли заставить видяху работать не на 85 Гц, а на 100?

В винде так у меня сотня герц пашет при 1024х768..

fly4life
cybermind
Только ещё один вопрос: можно ли заставить видяху работать не на 85 Гц, а на 100?

В винде так у меня сотня герц пашет при 1024х768..

В консоли:

gtf 1024 768 100

Вывалившуюся на экран строку ModeLine добавь в соответствующую секцию конфигурационного файла иксов (секция называется «Modes»). Затем в секции «Screen» переменной «Modes» самым первым значением утанови то, что находится в кавычках сгенерированной ModeLine (что-то вроде: «1024×768_100.00»).

Dr. Evil

cybermind, ссори, что не по теме (Саша уже все сказал), а за чем тебе 100? человеческй глаз, по-моему, не отличает частоту выше 85 Гц.

Zar
fly4life
В консоли:

gtf 1024 768 100

Фига! А я все время videogen’ом гемороился.

anonymous

Блин, и вправду же =)

http://www.benq.ru/serviceandsupport/library.cfm?ac=1&alid=391

DimkaS
Dr._Evil
cybermind, ссори, что не по теме (Саша уже все сказал), а за чем тебе 100? человеческй глаз, по-моему, не отличает частоту выше 85 Гц.

Частоту не отличает, но изменение картинки — может. У меня NEC FE791SB. Рабочий режим 1024х768@85Гц. Пробовал поставить 100 (в винде) — ощущается некоторая прибавка контраста и яркости. ИМХО… В лине еще не пробовал.

Кст, максимум в данном разрешении то ли 120, то ли 140.

Sasha2

А тогда зачем вообще такая частота (100 Гц заложена в видеокарты)?

Genie
А тогда зачем вообще такая частота (100 Гц заложена в видеокарты)?

она не заложена….

просто так получается для CRT мониторов делением максимального значения DotClock на частоту HorizSync и число строк в кадре.

таким образом, для, скажем, 640×480 может получиться и все 200Гц.

только, всё же, на частоту вертикальной развёртки тоже ставится ограничение — потому как от этого питается и анод кинескопа, а там чем больше частота — тем больше напряжение выходит (отсюда и более яркое изображение).

в общем, иди учить электросхемотехнику, там тебе это объяснят намного лучше.

Sasha2

Genie, да я то как раз это знаю.

Мне непонятно зачем тогда этот вопрос ставить применительно

к ограничениям человеческого глаза на воспринимаемые частоты.

Схемотехника — дело святое, а биология то тут при чем?

Genie

биология (с психологией) тут в том, что

  • есть физически порог чувствительности;


  • есть порог восприятия.

последний менее чувствителен. в разы.

таким образом, можно чувствовать, но этого не ощущать.

осознанно глазом мерцание воспринимается около 75Гц.

порог чувствительности зависит от человека, но где-то около 2мс — т.е. около 500Гц.

в расслабленном состоянии порог восприятия приближается к физической чувствительности, но и даже в этом случае разница очень большая.

лично я и 100Гц ощущаю. но это уже может от монитора тоже зависит.

потому как картинка может немного подёргиваться, становиться ярче/тусклее…

всё это в сумме и даёт ощущение.

Sasha2

А вот я, как ни таращусь на монитор, ну блин разницу между 85 Гц и 100 Гц не могу различить.

Более того, свой монитор я настраивал даже на 109 Гц (выше в 1600 x 1200 уже не могу, как правильно ты заметил из-за Pixel DotClock, выше в таком разрешении она уже не тянет).

Но блин, что при нормальной работе, что в состоянии дикого опьянения все равно не могу различить (визуально имеется в виду) никакой разницы. И никакого ни повышения, ни понижения производительности тоже не замечаю.

x_nori

Привет!

У меня такая проблемма с отображением:

Установил новые драйверы 8178 от nvidia.

Все работает нормально до момента когда я возвращаюсь из иксов в текстовый режим. После закрытия иксов буквы имеют немеренно огромный размер. Да вообщем то и вслучае если запускаешь другую вирт консоль. После перезагрузки в текст все нрмально.

Где то в нете прочитал что нада отключить фрейм буфер.

Если не сложно что это такое и как его тключить?

Заранее благодарен..

rgo
После закрытия иксов буквы имеют немеренно огромный размер

1) «немеряно огромный» это какой? 1/80 ширины экрана на 1/25 высоты? Ежели отключить использование фреймбуфера для консоли, то именно так и будет.

2) А если не убивать X, а просто alt-ctrl-F1 нажать?

Установил новые драйверы 8178 от nvidia.

3) а до этого на каких дровах крутились X’ы?

4) ОС, версия X, wm, ядро.

5) посмотри, после закрытия X в файлик /var/log/Xorg.0.log, может чего найдёшь там. еггог’ов каких-нибудь, например.

8084

Отвечу за него

Mandriva 2006 Download edition

Было — nv

rgo

главное — 1): хочется понять, что с фреймбуфером случается. И кстати, что за фреймбуфер используется? Параметры ядра передаваемые при загрузке неплохо было бы посмотреть.

x_nori

Привет!

Вобщем так !

Целые выходные сидел разбирался что за ерунда со шрифтом

Оказалось во как:

У меня подключен телевизор через S-video

Если отключить то все нормально.

Прочитал что можно прописать в конфиге:

Section «Device»

# должно помочь с кракозябликами…

Option «IgnoreDisplayDevices» «DFP, TV»

EndSection

Тоже все нормально даже при подключенном телеке

Однако возникла следующая проблемма после настройки twin view «Clone»

Появилась та же проблемма

Если не убивать иксы , а просто нажать ctrl+alt+F1, проблемма остается

Может чего посоветуете?

Да.. и при замене «nvidia» на «nv» тоже все нормально.

И может быть кто посоветует где можно почитать про все опции

xorg.config Желательно на русском.

Потому что все что нашел в нете это конкретные настройки для того или друго режима. А хотелось бы разобраться…

Вообщем вопросов еще немеренно , но уже стал малось чего понимать :)