nixp.ru v3.0

22 января 2017,
воскресенье,
17:23:27 MSK

DevOps с компанией «Флант»
Аватар пользователя DimkaS
DimkaS написал 15 июня 2006 года в 18:07 (448 просмотров) Ведет себя как мужчина; открыл 84 темы в форуме, оставил 922 комментария на сайте.

Поставил Debian Sarge 3.1 (тот, что прошлой осенью вышел). Собрал ядро 2.6.16.16. Никак не получается заставить работать встроенную сетевуху. Мамка ASUS K8N4-E Deluxe на чипе nForce4. Сетевуха Marvell 88E81111 Gigabit LAN PHY. В ядре отключил всё, что касалось 10/100 и 10000 Мбит, оставил только модуль для своей сетевухи. После перезагрузки её не видно. Попробовал поставить драйвер от nVidia, прописал в /etc/modprobe.d/aliases такую строку:

alias eth0 nvnet


Перезагрузился — модуль есть, итерфейса нет (т.е. делаю ifconfig eth0 up, ifconfig eth0 — никакого IP адреса не показывает).

Что я не так делаю?

8084

>ifconfig eth0 up

Может в сетке нет dhcp сервера?

Dr. Evil

давай начнем с этого

dmesg| egrep '(\net|\eth)'
lspci -v

есть ли у тебя пакеты mii-tool или ethtool? если есть, то давай результат выполнения их в консоли.

DimkaS

Прошу прощения, сам разобрался.

1) По недосмотру на eth0 попал firewire, а не lan.

2) драйвер Marvel, похоже, только для pci карточек. Нашел forcedeth в резделе 10/100. Работает.

3) Драйвер nvidia так и не заработал, даже собираться перестал. Ну его…

А вот еще вопрос: для автоконфигурации интерфейса мне пришлось ставить ethertool (кажись). А чем инсталлер все это дело конфигурирует?

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.