nixp.ru v3.0

21 октября 2017,
суббота,
19:04:55 MSK

DevOps с компанией «Флант»
denforce написал 23 августа 2006 года в 14:50 (571 просмотр) Ведет себя неопределенно; открыл 1 тему в форуме.

Камрады, мастера помогите справиться с такой проблемой. С Линуксом я стал знакомится совсем недавно. По работе потребовалось изучить Suse Linux (типа спецом по ём решили сделать меня). Ну и решился я заказать себе послденюю версию. Стал ставить. Во время установки все было красочно и просто замечательно. Сначала я выбрал 5-й уровень загрузки. После установки и перезагрузки как только началась грузиться система по моему LCD монитору забегали всякие цветные полосы, букашки и всякая дребедень. Ну, не понравился монитор системе подумал я. Через 2 следующие установки, я понял что делов в размазанной видюхе, а именно Intel 82915G. Загрузился я в сейф-моде и стал ставить всячиские дрова. И качал я самые последние дрова(ими оказались исходники X-ов) и предпосление которые дровами. Ничего не помогало. Но в итоге нашел дрова ,которые входил в дистрибутив. Поставил их. Ура, на 3-м уровне я смог работать в нормальном разрешении (раньше я мог работать только в сейф-моде). Но при старте X-ов система резко уходила на перезагрузку.

X -probeonly дало следующий результат:

X Window System Version 6.9.0

Release Date: 21 December 2005

X Protocol Version 11, Revision 0, Release 6.9

Build Operating System: SuSE Linux [ELF] SuSE

Current Operating System: Linux den 2.6.16.13-4-default #1 Wed May 3 04:53:23 UTC 2006 i686

Build Date: 02 May 2006

(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)

Я облазил несметное количество форумов (наших и не наших), да сходная проблема обсуждается, но единственный совет приемлемый для себя я нашел,что надо

в modprobe.conf прописать alias agpgart intel_agp. Затем выполнить modprobe agpgart. Ничего не помогло. Даже когда я умудрился загрузить этот модуль (он был в списке процессов). Но тогда вылезала ошибка что нет девайса /dev/agpgart. Подскажите что еще можно сделать?

Dr. Evil

самый простой, наверное, вариант — запустить в 3-ем ините sax2, который должен сделать все сам.

если это не помогает, то попробуй создать устройство agpart

вот его аналог в десятке.

drevil@SUSE10.0:~> l /dev/ | grep agp

crw——- 1 root video 10, 175 2006-08-21 08:48 agpgart

дай еще кусок messages, когда стартуют иксы.

а вообще, очень странно, что изз коробки у тебя все не заработало…