nixp.ru v3.0

17 октября 2017,
вторник,
03:18:20 MSK

DevOps с компанией «Флант»
Аватар пользователя vovans
vovans написал 30 сентября 2006 года в 11:36 (1252 просмотра) Ведет себя как мужчина; открыл 27 тем в форуме, оставил 418 комментариев на сайте.

Не пойму что делаю не так.

Правлю:

/etc/sane.d/snapscan.conf

usb 0×04b8 0×0120

firmware /usr/share/sane/snapscan/esfw3e.bin

Соответствующий файл туда кинул из венды. Всё по мануалам. Далее:

# sane-find-scanner | grep -i epson

found USB scanner (vendor=0×04b8 [EPSON], product=0×0120 [EPSON Scanner]) at libusb:005:002

Отлично!

# export SANE_DEBUG_SNAPSCAN=256

# scanimage -L

No scanners were identified. If you were expecting something different,

check that the scanner is plugged in, turned on and detected by the

sane-find-scanner tool (if appropriate). Please read the documentation

which came with this software (README, FAQ, manpages).

Почему????

Зато xsane и kooka сканер видят, по при попытки сканировать подвесают, или, бывает, что не находят сканер и надо его включить/выключить.

При подвисании xsane в дабаг-мессагах встречается такое:

[snapscan] Read 60928 bytes

[snapscan] read_calibration_data: snapscan_cmd command failed: Error during device I/O

[snapscan] calibrate: read_calibration_data command failed: Error during device I/O

[snapscan] sane_snapscan_start: calibration failed.

[snapscan] release_unit: scsi command error: Error during device I/O

[snapscan] usb_write: writing: 0×17 0×00 0×00 0×00 0×00 0×00

[snapscan] usb_write Only 0 bytes written

[snapscan] Written 0 bytes

[snapscan] release_unit: scsi command error: Error during device I/O

[snapscan] close_scanner

Да, а как только нажимаю на сканирование, оно выдаёт:

[snapscan] sense_handler: sense key: 0×02, asc: 0×04, ascq: 0×01, i1: 0×1f, i2: 0×00

[snapscan] sense_handler: Not ready.

[snapscan] sense_handler: Logical unit is in process of becoming ready. (31 seconds)

[snapscan] sense_handler: Not ready.

[snapscan] test_unit_ready: snapscan_cmd command failed: Device busy

[snapscan] Scanner warming up — waiting 31 seconds.

В итоге выдаётся сообщение xsane:

Не возможно инициализировать сканирование: Ошибкак во время ввода-вывода с устройством.

Вот беда с этим сканером :( Целый день провозился :(

vovans

на др машине сканер стал определятся по `scanimage -L`, но лучше не стало :(

# scanimage -L

[sanei_debug] Setting debug level of snapscan to 256.

[snapscan] sane_snapscan_init

[snapscan] sane_snapscan_init: Snapscan backend version 1.4.53

[snapscan] add_usb_device(libusb:004:008)

[snapscan] add_usb_device: Detected (kind of) an USB device

[snapscan] snapscani_usb_open(libusb:004:008)

[snapscan] add_usb_device: Checking if 0×04b8 is a supported USB vendor ID

[snapscan] snapscani_check_device()

[snapscan] mini_inquiry

[snapscan] snapscan_cmd

[snapscan] snapscani_usb_cmd(0,0xbffa89d0,6,0xbffa89a0,0xbffa899c (36))

[snapscan] atomic_usb_cmd(0,0xbffa89d0,6,0xbffa89a0,0xbffa899c (36))

[snapscan] usb_cmd(0,0xbffa89d0,6,0xbffa89a0,0xbffa899c (36))

[snapscan] usb_cmd: cmdlen=6, datalen=0

[snapscan] usb_write: writing: 0×12 0×00 0×00 0×00 0×24 0×00

[snapscan] Written 6 bytes

[snapscan] usb_read: reading: 0xf9 0×00 0×00 0×00 0×00 0×00 0×00 0×00

[snapscan] Read 8 bytes

[snapscan] usb_read: reading: 0×06 0×00 0×02 0×02 0×49 0×00 0×00 0×00 0×45 0×50 …

[snapscan] Read 36 bytes

[snapscan] usb_read: reading: 0xfb 0×00 0×00 0×00 0×00 0×00 0×00 0×00

[snapscan] Read 8 bytes

[snapscan] snapscani_check_device: Is vendor «EPSON» model «EPSON Scanner» a supported scanner?

[snapscan] snapscani_get_model_id(EPSON Scanner, 0, 2)

[snapscan] snapscani_get_model_id: looking up scanner for ID 0×04b8,0×0120.

[snapscan] snapscani_get_model_id: scanner identified

[snapscan] snapscani_check_device: Autodetected driver: Perfection 1270

[snapscan] snapscani_usb_close(0)

[snapscan] 1st read 3 write 1

[snapscan] snapscani_usb_cmd(0,0xbffa8a20,6,0×0,0×0 (0))

[snapscan] atomic_usb_cmd(0,0xbffa8a20,6,0×0,0×0 (0))

[snapscan] usb_cmd(0,0xbffa8a20,6,0×0,0×0 (0))

[snapscan] usb_cmd: cmdlen=6, datalen=0

[snapscan] usb_write: writing: 0×00 0×00 0×00 0×00 0×00 0×00

[snapscan] Written 6 bytes

[snapscan] usb_read: reading: 0xfb 0×00 0×00 0×00 0×00 0×00 0×00 0×00

[snapscan] Read 8 bytes

[snapscan] 2nd read 4 write 2

[snapscan] snapscani_init_device_structure()

[snapscan] sane_snapscan_get_devices (0xbffa9be8, 0)

device `snapscan:libusb:004:008\′ is a EPSON EPSON Scanner flatbed scanner

[snapscan] sane_snapscan_exit

vovans

Транно, по этой же схеме подключил Епсон 660-й и всё сразу заработало! А 1270 виснит и всё тут :(((