nixp.ru v3.0

24 мая 2017,
среда,
10:57:24 MSK

DevOps с компанией «Флант»
alterious написал 16 августа 2006 года в 13:40 (368 просмотров) Ведет себя неопределенно; открыл 3 темы в форуме, оставил 9 комментариев на сайте.

У меня две звуковые карты Creative SB Adigy LS и Soundmax Integrated Digital Audio (встроенная). Creative под Linux никогда нормально не работала из принципа, ну и фиг с ней, а вод Soundmax прекрасно работала под ядром 2.6.3. Поставил ядро 2.6.17

и звук пропал вообще. Ядро собирал с конфигой от ядра 2.6.3. Поставил alsa-driver

самый свежий — не помогло. И что самое интересное карта Soundmax под 2.6.17 определяется также, как и под 2.6.3 и драйвер её подписан точно также, но звука нет и всё тут. Help me please.

OS : Mandrake 10.0

xserver : XFree86

window manager : KDE 3.2

Dr. Evil

звуковая схема какая используется?

давай вывод

lsmod | grep snd


Ядро собирал с конфигой от ядра 2.6.3.

расскажи, как ты это смог сделать… :)

ADL

ааа… объясните плиз… я знаю, звук(загр. модули) ставится либо из ядра, либо из пакета(модуль — alsa-driver)

Dr. Evil

так что, собственно, тебе объяснять надо?

alterious

#lsmod | grep snd

snd_pcm_oss 48000 0

snd_mixer_oss 19360 1 snd_pcm_oss

snd_intel8×0 35164 0

snd_ac97_codec 97092 1 snd_intel8×0

snd_ac97_bus 3264 1 snd_ac97_codec

snd_pcm 83556 3 snd_pcm_oss,snd_intel8×0,snd_ac97_codec

snd_timer 25412 1 snd_pcm

snd_page_alloc 11848 2 snd_intel8×0,snd_pcm

snd 57924 6 snd_pcm_oss,snd_mixer_oss,snd_intel8×0,snd_ac97_codec,snd_pcm,snd_timer

soundcore 11008 1 snd

Я загрузил старый конфиг старого ядра с помощью menuconfig, возможно, он и не загрузился, а конфиг остался дефолтовский. Впрочем, я пытался сначала сделать новый конфиг, но проблеммы были те же.

Dr. Evil

так, понятно — у тебя oss. может, те, кто используют эту схему, знают о чем-то подобном alsaconf.

alterious, а не пробовал увеличивать звук в миксере?

у тебя, кстати, где нет звука?

давай вывод

dmesg
alterious

Пробовал, в Kmix и в alsamixer — результат нулевой. Звука нет нигде: ни в xmms (какой бы модуль я ему ни выбирал alsa или oss), ни в Totem, ни при загрузке Kde (есть там звуковая тема).

[root@localhost root]# dmesg

Linux version 2.6.17 (root@localhost) (gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)) #2 SMP Tue Aug 15 00:15:09 MSD 2006

BIOS-provided physical RAM map:

BIOS-e820: 0000000000000000 — 000000000009fc00 (usable)

BIOS-e820: 000000000009fc00 — 00000000000a0000 (reserved)

BIOS-e820: 00000000000e8000 — 0000000000100000 (reserved)

BIOS-e820: 0000000000100000 — 000000003ffb0000 (usable)

BIOS-e820: 000000003ffb0000 — 000000003ffc0000 (ACPI data)

BIOS-e820: 000000003ffc0000 — 000000003fff0000 (ACPI NVS)

BIOS-e820: 000000003fff0000 — 0000000040000000 (reserved)

BIOS-e820: 00000000ffb80000 — 0000000100000000 (reserved)

127MB HIGHMEM available.

896MB LOWMEM available.

found SMP MP-table at 000ff780

On node 0 totalpages: 262064

DMA zone: 4096 pages, LIFO batch:0

Normal zone: 225280 pages, LIFO batch:31

HighMem zone: 32688 pages, LIFO batch:7

DMI 2.3 present.

ACPI: RSDP (v000 ACPIAM ) @ 0×000fad60

ACPI: RSDT (v001 A M I OEMRSDT 0×02000517 MSFT 0×00000097) @ 0×3ffb0000

ACPI: FADT (v002 A M I OEMFACP 0×02000517 MSFT 0×00000097) @ 0×3ffb0200

ACPI: MADT (v001 A M I OEMAPIC 0×02000517 MSFT 0×00000097) @ 0×3ffb0390

ACPI: OEMB (v001 A M I OEMBIOS 0×02000517 MSFT 0×00000097) @ 0×3ffc0040

ACPI: DSDT (v001 A0049 A0049000 0×00000000 INTL 0×02002026) @ 0×00000000

ACPI: PM-Timer IO Port: 0×808

ACPI: Local APIC address 0xfee00000

ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)

Processor #0 15:4 APIC version 20

ACPI: LAPIC (acpi_id[0x02] lapic_id[0x81] disabled)

Using ACPI for processor (LAPIC) configuration information

Intel MultiProcessor Specification v1.4

Virtual Wire compatibility mode.

OEM ID: ASUSTeK Product ID: P4P800SE APIC at: 0xFEE00000

I/O APIC #1 Version 32 at 0xFEC00000.

Enabling APIC mode: Flat. Using 1 I/O APICs

Processors: 1

Allocating PCI resources starting at 50000000 (gap: 40000000:bfb80000)

Built 1 zonelists

Kernel command line: BOOT_IMAGE=linux_2.6.17-new ro root=306 devfs=mount acpi=ht splash=silent

mapped APIC to ffffd000 (fee00000)

mapped IOAPIC to ffffc000 (fec00000)

Enabling fast FPU save and restore… done.

Enabling unmasked SIMD FPU exception support… done.

Initializing CPU#0

PID hash table entries: 4096 (order: 12, 16384 bytes)

Detected 2673.475 MHz processor.

Using pmtmr for high-res timesource

Console: colour dummy device 80×25

Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)

Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)

Memory: 1034824k/1048256k available (2143k kernel code, 12832k reserved, 775k data, 316k init, 130752k highmem)

Checking if this processor honours the WP bit even in supervisor mode… Ok.

Calibrating delay using timer specific routine.. 5351.50 BogoMIPS (lpj=10703009)

Mount-cache hash table entries: 512

CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 0000441d 00000000 00000000

CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 0000441d 00000000 00000000

monitor/mwait feature present.

using mwait in idle threads.

CPU: Trace cache: 12K uops, L1 D cache: 16K

CPU: L2 cache: 256K

CPU: Hyper-Threading is disabled

CPU: After all inits, caps: bfebfbff 00000000 00000000 00000180 0000441d 00000000 00000000

Intel machine check architecture supported.

Intel machine check reporting enabled on CPU#0.

CPU0: Intel P4/Xeon Extended MCE MSRs (12) available

CPU0: Thermal monitoring enabled

Checking 'hlt' instruction… OK.

SMP alternatives: switching to UP code

Freeing SMP alternatives: 16k freed

CPU0: Intel(R) Celeron(R) CPU 2.66GHz stepping 01

Total of 1 processors activated (5351.50 BogoMIPS).

ExtINT not setup in hardware but reported by MP table

ENABLING IO-APIC IRQs

..TIMER: vector=0×31 apic1=0 pin1=2 apic2=0 pin2=0

alterious

Brought up 1 CPUs

migration_cost=0

checking if image is initramfs…it isn’t (no cpio magic); looks like an initrd

Freeing initrd memory: 181k freed

NET: Registered protocol family 16

EISA bus registered

PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=2

Setting up standard PCI resources

ACPI: Subsystem revision 20060127

ACPI: Interpreter disabled.

Linux Plug and Play Support v0.97 (c) Adam Belay

pnp: PnP ACPI: disabled

ASUS P4P800 detected. Disabling PnPBIOS

PnPBIOS: Disabled

PCI: Probing PCI hardware

PCI: Probing PCI hardware (bus 00)

PCI quirk: region 0800-087f claimed by ICH4 ACPI/GPIO/TCO

PCI quirk: region 0480-04bf claimed by ICH4 GPIO

PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1

Boot video device is 0000:01:00.0

PCI: Transparent bridge — 0000:00:1e.0

PCI: Using IRQ router PIIX/ICH [8086/24d0] at 0000:00:1f.0

PCI->APIC IRQ transform: 0000:00:1d.0[A] -> IRQ 16

PCI->APIC IRQ transform: 0000:00:1d.1 -> IRQ 19

PCI->APIC IRQ transform: 0000:00:1d.2[C] -> IRQ 18

PCI->APIC IRQ transform: 0000:00:1d.3[A] -> IRQ 16

PCI->APIC IRQ transform: 0000:00:1d.7[D] -> IRQ 23

PCI->APIC IRQ transform: 0000:00:1f.1[A] -> IRQ 18

PCI->APIC IRQ transform: 0000:00:1f.3 -> IRQ 17

PCI->APIC IRQ transform: 0000:00:1f.5 -> IRQ 17

PCI->APIC IRQ transform: 0000:01:00.0[A] -> IRQ 16

PCI->APIC IRQ transform: 0000:02:05.0[A] -> IRQ 22

PCI->APIC IRQ transform: 0000:02:09.0[A] -> IRQ 21

PCI->APIC IRQ transform: 0000:02:0a.0[A] -> IRQ 22

PCI->APIC IRQ transform: 0000:02:0b.0[A] -> IRQ 23

PCI: Bridge: 0000:00:01.0

IO window: disabled.

MEM window: fc900000-fe9fffff

PREFETCH window: e7f00000-f7efffff

PCI: Bridge: 0000:00:1e.0

IO window: d000-dfff

MEM window: fea00000-feafffff

PREFETCH window: 50000000-500fffff

PCI: Setting latency timer of device 0000:00:1e.0 to 64

NET: Registered protocol family 2

IP route cache hash table entries: 32768 (order: 5, 131072 bytes)

TCP established hash table entries: 131072 (order: 8, 1048576 bytes)

TCP bind hash table entries: 65536 (order: 7, 524288 bytes)

TCP: Hash tables configured (established 131072 bind 65536)

TCP reno registered

apm: BIOS version 1.2 Flags 0×03 (Driver version 1.16ac)

highmem bounce pool size: 64 pages

VFS: Disk quotas dquot_6.5.1

Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

Initializing Cryptographic API

io scheduler noop registered

io scheduler anticipatory registered (default)

io scheduler deadline registered

io scheduler cfq registered

vesafb: framebuffer at 0xe8000000, mapped to 0xf8800000, using 1875k, total 131072k

vesafb: mode is 800×600x16, linelength=1600, pages=2

vesafb: protected mode interface info at c000:e330

vesafb: scrolling: redraw

vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0

Console: switching to colour frame buffer device 100×37

fb0: VESA VGA frame buffer device

isapnp: Scanning for PnP cards…

isapnp: No Plug & Play device found

Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled

serial8250: ttyS0 at I/O 0×3f8 (irq = 4) is a 16550A

serial8250: ttyS1 at I/O 0×2f8 (irq = 3) is a 16550A

RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

ICH5: IDE controller at PCI slot 0000:00:1f.1

PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)

ICH5: chipset revision 2

ICH5: not 100% native mode: will probe irqs later

ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:DMA

ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:pio

Probing IDE interface ide0…

hda: ST3300622A, ATA DISK drive

hdb: Maxtor 6Y080P0, ATA DISK drive

ide0 at 0×1f0-0×1f7,0×3f6 on irq 14

Probing IDE interface ide1…

hdc: _NEC DVD_RW ND-3540A, ATAPI CD/DVD-ROM drive

ide1 at 0×170-0×177,0×376 on irq 15

hda: max request size: 512KiB

hda: 586072368 sectors (300069 MB) w/16384KiB Cache, CHS=36481/255/63, UDMA(100)

hda: cache flushes supported

hda: hda1 hda2 < hda5 hda6 > hda3

hdb: max request size: 128KiB

hdb: 160086528 sectors (81964 MB) w/7936KiB Cache, CHS=65535/16/63, UDMA(100)

hdb: cache flushes supported

hdb: hdb1 hdb2 < hdb5 hdb6 >

PNP: No PS/2 controller found. Probing ports directly.

serio: i8042 AUX port at 0×60,0×64 irq 12

serio: i8042 KBD port at 0×60,0×64 irq 1

mice: PS/2 mouse device common for all mice

md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27

md: bitmap version 4.39

EISA: Probing bus 0 at eisa.0

TCP bic registered

NET: Registered protocol family 1

Using IPI Shortcut mode

BIOS EDD facility v0.16 2004-Jun-25, 2 devices found

md: Autodetecting RAID arrays.

md: autorun …

md: … autorun DONE.

RAMDISK: Compressed image found at block 0

VFS: Mounted root (ext2 filesystem).

input: AT Translated Set 2 keyboard as /class/input/input0

ReiserFS: hda6: found reiserfs format «3.6» with standard journal

input: ImPS/2 Generic Wheel Mouse as /class/input/input1

ReiserFS: hda6: using ordered data mode

ReiserFS: hda6: journal params: device hda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30

ReiserFS: hda6: checking transaction log (hda6)

ReiserFS: hda6: replayed 23 transactions in 10 seconds

ReiserFS: hda6: Using r5 hash to sort names

VFS: Mounted root (reiserfs filesystem) readonly.

Trying to move old root to /initrd … okay

Freeing unused kernel memory: 316k freed

alterious

Real Time Clock Driver v1.12ac

usbcore: registered new driver usbfs

usbcore: registered new driver hub

USB Universal Host Controller Interface driver v3.0

PCI: Setting latency timer of device 0000:00:1d.0 to 64

uhci_hcd 0000:00:1d.0: UHCI Host Controller

uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1

uhci_hcd 0000:00:1d.0: irq 16, io base 0×0000ef00

usb usb1: configuration #1 chosen from 1 choice

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 2 ports detected

PCI: Setting latency timer of device 0000:00:1d.1 to 64

uhci_hcd 0000:00:1d.1: UHCI Host Controller

uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2

uhci_hcd 0000:00:1d.1: irq 19, io base 0×0000ef20

usb usb2: configuration #1 chosen from 1 choice

hub 2-0:1.0: USB hub found

hub 2-0:1.0: 2 ports detected

PCI: Setting latency timer of device 0000:00:1d.2 to 64

uhci_hcd 0000:00:1d.2: UHCI Host Controller

uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3

uhci_hcd 0000:00:1d.2: irq 18, io base 0×0000ef40

usb usb3: configuration #1 chosen from 1 choice

hub 3-0:1.0: USB hub found

hub 3-0:1.0: 2 ports detected

PCI: Setting latency timer of device 0000:00:1d.3 to 64

uhci_hcd 0000:00:1d.3: UHCI Host Controller

uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4

uhci_hcd 0000:00:1d.3: irq 16, io base 0×0000ef80

usb usb4: configuration #1 chosen from 1 choice

hub 4-0:1.0: USB hub found

hub 4-0:1.0: 2 ports detected

PCI: Setting latency timer of device 0000:00:1d.7 to 64

ehci_hcd 0000:00:1d.7: EHCI Host Controller

ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5

ehci_hcd 0000:00:1d.7: debug port 1

PCI: cache line size of 128 is not supported by device 0000:00:1d.7

ehci_hcd 0000:00:1d.7: irq 23, io mem 0xfebffc00

ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004

usb usb5: configuration #1 chosen from 1 choice

hub 5-0:1.0: USB hub found

hub 5-0:1.0: 8 ports detected

Adding 506008k swap on /dev/hda5. Priority:-1 extents:1 across:506008k

SCSI subsystem initialized

imm: Version 2.05 (for Linux 2.4.0)

parport0: PC-style at 0×378 [PCSPP]

ppa: Version 2.07 (for Linux 2.4.x)

Linux agpgart interface v0.101 (c) Dave Jones

agpgart: Detected an Intel 865 Chipset.

agpgart: AGP aperture is 64M @ 0xf8000000

kjournald starting. Commit interval 5 seconds

EXT3 FS on hda1, internal journal

EXT3-fs: mounted filesystem with ordered data mode.

NTFS driver 2.1.27 [Flags: R/O MODULE].

NTFS volume version 3.1.

NTFS volume version 3.1.

ieee1394: Initialized config rom entry `ip1394\′

ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[23] MMIO=[feafa800-feafafff] Max Packet=[2048] IR/IT contexts=[4/8]

ieee1394: Host added: ID:BUS[0-00:1023] GUID[001106660000017d]

eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)

Floppy drive(s): fd0 is 1.44M

FDC 0 is a post-1991 82077

hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)

Uniform CD-ROM driver Revision: 3.20

NET: Registered protocol family 17

PCI: Setting latency timer of device 0000:00:1f.5 to 64

intel8×0_measure_ac97_clock: measured 52086 usecs

intel8×0: clocking to 48000

nvidia: module license 'NVIDIA' taints kernel.

NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-7182 Wed Apr 19 12:56:13 PDT 2006

agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.

agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode

agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode

agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.

agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode

agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode

atkbd.c: Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying access hardware directly.

Dr. Evil
Пробовал, в Kmix и в alsamixer — результат нулевой. Звука нет нигде: ни в xmms (какой бы модуль я ему ни выбирал alsa или oss), ни в Totem, ни при загрузке Kde (есть там звуковая тема).

alsamixer нам не подойдет — у тебя oss. нужен аналог миксера для oss. его я, к сожалению, не знаю.

судя по выводу dmesg, у тебя карта операционкой видна… это радует :)

скажи, что гворит kmix, если его перезапустить?

есть ли у тебя в папке /dev файл dsp?

покажи, что есть в каталоге /dev/snd

alterious

[root@localhost root]# kmix

kmix: ERROR: Alsa mixer cannot be found.

Please check that the soundcard is installed and the

soundcard driver is loaded.

kmix:

kmix: ERROR: Alsa mixer cannot be found.

Please check that the soundcard is installed and the

soundcard driver is loaded.

kmix:

/dev:

dsp, dsp0, dsp1, dsp2, dsp3, dsp56k

/dev/snd ls:

controlC0 hwC1D2 midiC0D0 midiC1D2 midiC2D4 midiC3D6 pcmC0D4c pcmC1D1c pcmC1D6c pcmC2D3c pcmC3D0c pcmC3D5c

controlC1 hwC1D3 midiC0D1 midiC1D3 midiC2D5 midiC3D7 pcmC0D4p pcmC1D1p pcmC1D6p pcmC2D3p pcmC3D0p pcmC3D5p

controlC2 hwC2D0 midiC0D2 midiC1D4 midiC2D6 pcmC0D0c pcmC0D5c pcmC1D2c pcmC1D7c pcmC2D4c pcmC3D1c pcmC3D6c

controlC3 hwC2D1 midiC0D3 midiC1D5 midiC2D7 pcmC0D0p pcmC0D5p pcmC1D2p pcmC1D7p pcmC2D4p pcmC3D1p pcmC3D6p

hwC0D0 hwC2D2 midiC0D4 midiC1D6 midiC3D0 pcmC0D1c pcmC0D6c pcmC1D3c pcmC2D0c pcmC2D5c pcmC3D2c pcmC3D7c

hwC0D1 hwC2D3 midiC0D5 midiC1D7 midiC3D1 pcmC0D1p pcmC0D6p pcmC1D3p pcmC2D0p pcmC2D5p pcmC3D2p pcmC3D7p

hwC0D2 hwC3D0 midiC0D6 midiC2D0 midiC3D2 pcmC0D2c pcmC0D7c pcmC1D4c pcmC2D1c pcmC2D6c pcmC3D3c seq

hwC0D3 hwC3D1 midiC0D7 midiC2D1 midiC3D3 pcmC0D2p pcmC0D7p pcmC1D4p pcmC2D1p pcmC2D6p pcmC3D3p timer

hwC1D0 hwC3D2 midiC1D0 midiC2D2 midiC3D4 pcmC0D3c pcmC1D0c pcmC1D5c pcmC2D2c pcmC2D7c pcmC3D4c

hwC1D1 hwC3D3 midiC1D1 midiC2D3 midiC3D5 pcmC0D3p pcmC1D0p pcmC1D5p pcmC2D2p pcmC2D7p pcmC3D4p

Genie

alsa-utils, alsa-conf и прочее установлено?

alterious

Установлено. Никто, случайно не знает, как натравить звуковую карту на alsa-driver, при том, что сейчас она использует OSS (alsa-driver установлен)

Dr. Evil

если, все, что у тебя спрашивали тебя установлено, то просто выполни в консоле alsaconf. в конце всех операций, которые будет вополнять этот скрипт, должен воспроизвестись звук.

alterious

пробовал, вконце, вроде что-то щёлкнуло, но в остальных местах не заработал, да и там — то скорее наведённые помехи

Dr. Evil

вряд ли это были наведенные помехи. там просто проигрывается семпл длиною в 3 сек.

где в других местах нет звука? в КДЕ? какая звуковая схема сейчас используется?

alsa какой версии?

8084

Че ты хочешь то.

В мандраке 10 нету udev.

А 17-му ядру надо удев, оно не подедрживает более devfs.

Соотв-но файлы устройств не создаются, ставь 12 или 13-ое.

k0st1k

Что-бы тему новую не создавать спрошу сдесь. Запускаю sndconfig определяет мою карту Cristal и т.д. Музыку играет и сохроняет modules.conf. Что дальше то делать, где что прописать надо.

fly4life
k0st1k
Что-бы тему новую не создавать спрошу сдесь. Запускаю sndconfig определяет мою карту Cristal и т.д. Музыку играет и сохроняет modules.conf. Что дальше то делать, где что прописать надо.

А чего надо-то?

k0st1k

Чтобы звук работал

fly4life
k0st1k
Чтобы звук работал

Эээ… ты ж сам сказал:

Запускаю sndconfig определяет мою карту Cristal и т.д. Музыку играет и сохроняет modules.conf.

Что тогда не работает?

k0st1k

Может я что-то не догоняю. Он что должен работать после того как modules.config сохранится. я запускаю kmix и на нём крест стоит. Может погромче надо сделать? Только КАК? И вообще кто нибудь может описать свои действия пошагово после того как modules.config сохранился. К примеру: я выхожу из sndconfig и т.д.

Dr. Evil

крест на динамике kmix может стоять из-за: отстуствие микшера, mute на выводе. открой kmix и подвигай ползунок «Выход».

звуковая схема какая используется? alsa или oss?

k0st1k

Там нет никакого ползунка. Написано не удалось найти микшер. звук стоит автоопределение

Dr. Evil

раз микшер не найден, значит — нет устройства /dev/dsp.

какая звукавая схема тобой используется?

k0st1k

alsa

Dr. Evil

если ты выполнял alsaconfig, то все устройства должны быть созданы. ты можешь перенаправить вывод в файл процесс запуска kmix?

netmaster

Пробуй в harddrake модуль начинающися на snd-… (это под альсу), необходимые пакеты подтянутся сами, обычно получается. И еще, не факт что хммс после этого поет под альса плагин, чаще под артс.