nixp.ru v3.0

23 октября 2017,
понедельник,
21:55:35 MSK

DevOps с компанией «Флант»
Vima написал 13 апреля 2004 года в 09:43 (394 просмотра) Ведет себя неопределенно; открыл 36 тем в форуме, оставил 205 комментариев на сайте.

Подскажите, как можно отключить этот autorun — т.е. это когда диск в привод вставляешь, система автоматически его монтирует и запускается файловый менеджер какой-нибудь для просмотра содержимого.

Дело в том, что если при загрузке системы этот диск не дай бог окажется в приводе, у меня система страшно виснет. Ничто не помогает, даже перезагрузить обычными средствами не удается. Приходится жать на Reset, а это опасно…

ЗЫ. Я удалила некий файл .autorun.lck из домашнего каталога.

Что это вообще за файл такой?

Но так или иначе, на систему это не произвело должного впечатления — диск по-прежнему пытается запуститься сам…

Genie

ммм… хоть дистрибутив бы свой указывала, а то вспоминать да рыться по форуму тяжко..

посмотри в районе (был аналогичный вопрос на англоязычном форуме)

It is very easy …

system->configuration->hardware->cd properties.

simple.

Vima

ASPLinux…

Да, в Красной Шапке все решалось моментально :(.

Такой дистр угробили…

Anarchist

В /etc/fstab поставь опцию noauto

ЗЫ: Это вроде от дистра не зависит.

Longobard

убери из стартовых скритпов запуск autorun.

fly4life
LONGOBARD
убери из стартовых скритпов запуск autorun.

Нету такого в ASP’е.

Longobard

Шо значит нету? Стартовых скриптов нету или autorun нету?

fly4life
LONGOBARD
Шо значит нету? Стартовых скриптов нету или autorun нету?

А если немного подумать и не разводить флейм? Нету стартового скрипта 'autorun’.

df_0903

У меня эта вредная штука называется autofs (RH 9.0)

А уще есть древняя программка со странным названием ntsysv,

которая помогает отключать службы. Ее надо запускать из xterm или

чего-то подобного.

pol

Анархист прав «В /etc/fstab поставь опцию noauto »

Единственный нормальный выход,

после этого монтировать с помощью скрипта,

или если в аспе есть, не помню, то на вкладке свойтв CD есть функция «монтировать»

Кстати во всех линуксах с которыми работал наоборот после обращения через файловый менеджер к CD происходит его монтирование, хотя

содержание fstab

/dev/hda2 / reiserfs notail 1 1

none /dev/pts devpts mode=0620 0 0

/dev/hda5 /home reiserfs notail 1 2

/dev/hda6 /mnt/bakap jfs defaults 1 2

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=koi8-u,codepage=866,noauto,ro,exec 0 0

/dev/hda7 /mnt/windows vfat umask=0,iocharset=koi8-u,codepage=866 0 0

none /proc proc defaults 0 0

none /tmp tmpfs defaults 0 0

/dev/hda1 swap swap defaults 0 0

Кстати я так и не понял если меняем koi8-u на koi8-r шрифты не правильно отображаются (глюк замеченный мной только у Mandrake)

Vima

Ничего не понимаю.

Файл /etc/fstab:

# /etc/fstab: static file system information.

#

#

/dev/hdb5 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0

none /dev/shm tmpfs defaults 0 0

none /dev/pts/ devpts gid=5,mode=620 0 0

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro,iocharset=cp1251 0 0

/dev/fd0 /mnt/floppy auto noauto,owner,kudzu,iocharset=cp1251,codepage=866 0 0

/dev/hdb1 /mnt/win vfat auto,umask=0027,showexec,uid=500,gid=500,iocharset=cp1251 0 0

/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro,iocharset=cp1251 0 0

/dev/hda1 /mnt/win2 vfat auto,umask=0027,showexec,uid=500,gid=500,iocharset=cp1251 0 0

Вон же, стоит уже noauto. Так какого черта…

В RedHat, помню, в домашнем каталоге был файл типа autorun. Так вот — его удаляешь, и никаких проблем. В этом ASP же… :(

pol

Vima попробуй отключить kudzu,

сравни

у меня :

/dev/cdrom /mnt/cdrom auto umask=0,user,iocharset=koi8-u,codepage=866,noauto,ro,exec 0 0

у тебя:

/dev/cdrom    /mnt/cdrom    udf,iso9660 noauto,owner,kudzu,ro,iocharset=cp1251 0 0

Есть предположение что этот параметр как раз и приводит к этому.

А autorun тут не причём.

Vima
pol
Vima попробуй отключить kudzu

Да нет, Kudzu тут ни при чем. Она новые устройства автоматически определяет.

А это просто автозагрузка содержимого дисков…

pol

Ты не поняла не службу вообще, а пораметр

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,

!!!!kudzu!!!!! ,ro,iocharset=cp1251 0 0

Смотри служба как ты и говоришь определяет новые устройства, тогда какова роль этого параметра в fstab?

Vima
pol
Смотри служба как ты и говоришь определяет новые устройства, тогда какова роль этого параметра в fstab?

Хорошо, я попробую это затереть…

Только у меня в /etc/fstab вообще много фигни всякой понаписано.

df_0903

Параметр kudzu здесь ни при чем. У меня он тоже есть, но никакого

автомонтирования не происходит. Скорее всего это какая-нибудь служба.

Если не autofs, то что-нибудь подобное.

pol

Для эксперимента снёс Mandrake 10.0 (благо есть имидж / и /home)

поставил ASP 9.2, та же проблема что и у Vima, хотя нет ни одной службы которая может к этому приводить, попробую отследить через список процессов в системе, Какой новый появится или какой увеличит потребление ресурсов, Vima то же попробуй.

Блин просто интересно в чём фишка?

Genie

Вставь диск в привод

в момент запуска (разгона диска) от root-а

# fuser -auv /dev/cdrom

Vima
Genie
Вставь диск в привод

в момент запуска (разгона диска) от root-а

# fuser -auv /dev/cdrom

С превеликой радостью, да только я повторюсь — комп тут же смертельно виснет. Ничего вообще не запускается и не нажимается, кроме кнопки Reset. :) Ну или кнопки Power…

Anarchist
Vima
С превеликой радостью, да только я повторюсь — комп тут же смертельно виснет. Ничего вообще не запускается и не нажимается, кроме кнопки Reset. :) Ну или кнопки Power…

И Ctrl_Alt_F1 тоже не срабатывает?

Vima
Anarchist
И Ctrl_Alt_F1 тоже не срабатывает?

Да нет, тоже не срабатывает. Ничего не срабатывает.

Компьютер намертво виснет — ничего, кроме вращения диска, не выполняет.

Причем ему, похоже, это не надоедает — с полчасика послушаешь и сам уже зависать начинаешь.

Я не прикалываюсь (для тех, кто вдруг уже сомневаться начал)…

:(

Что-то клонит меня уже к мысли, что дело не в системе, дело в самом приводе (Mitsumi) и возможном конфликте между ним и системой.

Хотя, есть еще второй привод. Так вот там вроде то же самое…

Vima

Сейчас проверила со вторым приводом. Там все нормально.

В смысле, autorun запускается, но система не зависает при этом.

Вывод: дело в самом приводе.

Этот Mitsumi — он, вообще-то, пишущий… И вообще он какой-то кривой.