nixp.ru v3.0

20 января 2017,
пятница,
19:12:17 MSK

DevOps с компанией «Флант»
Uncle Theodore написал 22 января 2005 года в 20:08 (761 просмотр) Ведет себя неопределенно; открыл 58 тем в форуме, оставил 1537 комментариев на сайте.

Ядро 2.6.10, экспериментирую. ACPI скомпилено по-максимуму

cat /usr/src/linux-2.6.10/.config | grep ACPI

# Power management options (ACPI, APM)

# ACPI (Advanced Configuration and Power Interface) Support

CONFIG_ACPI=y

CONFIG_ACPI_BOOT=y

CONFIG_ACPI_INTERPRETER=y

CONFIG_ACPI_SLEEP=y

CONFIG_ACPI_SLEEP_PROC_FS=y

CONFIG_ACPI_AC=y

CONFIG_ACPI_BATTERY=y

CONFIG_ACPI_BUTTON=y

# CONFIG_ACPI_VIDEO is not set

CONFIG_ACPI_FAN=y

CONFIG_ACPI_PROCESSOR=y

CONFIG_ACPI_THERMAL=y

# CONFIG_ACPI_ASUS is not set

# CONFIG_ACPI_IBM is not set

# CONFIG_ACPI_TOSHIBA is not set

CONFIG_ACPI_BLACKLIST_YEAR=0

# CONFIG_ACPI_DEBUG is not set

CONFIG_ACPI_BUS=y

CONFIG_ACPI_EC=y

CONFIG_ACPI_POWER=y

CONFIG_ACPI_PCI=y

CONFIG_ACPI_SYSTEM=y

CONFIG_PNPACPI=y

CONFIG_SERIAL_8250_ACPI=y

Тем не менее, acpid, который читает /proc/acpi/event не реагирует ни на одну кнопку (POWER, LID, SLEEP), поскольку в этом файле ничего не появляется!

Когда-то давно, все это работало, кажется, в Слаке 9.1. Читал форумы acpi — ни у кого такой проблемы нет… А что делать?

Good Luck,

UT

Genie

а вот у меня оно не то, чтобы пустое… но ничего оттуда не выводится..

при этом, что странно,

$ zgrep ACPI /proc/config.gz
# Power management options (ACPI, APM)
# ACPI (Advanced Configuration and Power Interface) Support
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
CONFIG_ACPI_ASUS=m
CONFIG_ACPI_IBM=m
CONFIG_ACPI_TOSHIBA=m
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_POWERNOW_K7_ACPI=y
CONFIG_X86_POWERNOW_K8_ACPI=y
# CONFIG_X86_ACPI_CPUFREQ_PROC_INTF is not set
CONFIG_HOTPLUG_PCI_ACPI=y
CONFIG_HOTPLUG_PCI_ACPI_IBM=y
CONFIG_SERIAL_8250_ACPI=y


ни на одну кнопку (POWER, LID, SLEEP)

ммм. не проверял.. :)

надо будет, как очередной зуд по перекомпиляции ядра и смене натроек приключится..

Genie
но ничего оттуда не выводится..

в том смысле, что cat /proc/acpi/event завершается только по ctrl-c

надо будет, как очередной зуд

однако, работает кнопочка Power. комп нормально выключился.

может это надо тебе обновить acpid?

вот что у меня сломалось в 2.6.10 — это sensors.

немного поменялось название чипа it87-* на it8712-*, поэтому теперь по команде sensors многого не увдеть.. надо обновлять…

Uncle Theodore

Да в том-то и дело, что acpid читает /proc/acpi/event, я останавливаю acpid’а, запускаю cat /proc/acpi/event и нажимаю на всякие кнопочки, а в ем ничего не появляется…

Good Luck,

UT

Genie


# service acpid stop
Stopping Advanced Configuration and Power Interface daemon: acpid.
# cat /proc/acpi/event
button/power PWRF 00000080 00000001
button/power PWRF 00000080 00000002
# service acpid start
Starting Advanced Configuration and Power Interface daemon: acpid.
#

ммм..

кстати, вспоминается, что в 2.6.9 я тоже статично включал ACPI весь. не работала кнопка…

я из-за этого чуть не опоздал… :(

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.