nixp.ru v3.0

27 мая 2017,
суббота,
12:51:00 MSK

DevOps с компанией «Флант»
mdog288 написал 12 июня 2007 года в 20:55 (447 просмотров) Ведет себя как мужчина; открыл 1 тему в форуме, оставил 2 комментария на сайте.

Материал взят с альтернативного форума Брянской информационной сети «Брянское Метро»

Сегодня я расскажу как сделать ваши разделы с NTFS доступными для чтения и записи.

На сегодняшний день имеються не мало проектов в этой области я же расскажу про проверенным мной лично.

Для того, что бы собрать пакет ntfs-3g (www.ntfs-3g.org) понадобиться еще один пакет fuse, который уже имееться в вашей системе но возможно понадобиться его обновление. На текущий момент требуеться Fuse >=2.6.0 скачать его можно вот от сюда (fuse.sf.net)

Дальше собираем Fuse с модулем для ядра.

#cd fuse-2.6.0

#./configure --enable-kernel-module

#make

#make install

Теперь собираем htfs-3g

#./configure

#make

#make install

Далее настраиваем наши NTFS разделы.

#vim /etc/fstab

———-- Пример монтирования ——————————————————

/dev/hda6 /mnt/win_d ntfs-3g locale=ru_RU.koi8r,users,rw,exec,defaults 0 0

——————————————————————————————--

/dev/hda6 — раздел с ntfs

/mnt/win_d — точка монтирования

ntfs-3g — тип используемой файловой системы

#Параметры для монтирования

locale=ru_RU.koi8r — обеспечение локации файлов на русском языке (#locale -a)

users — доступ для обычных пользователей

rw — запись и чтение раздела

exec — разрешить исполняемые файлы

Далее рекомендую либо рестарнуть систему для подгрузки модула и цепления разделов или подцепить модуль и выполнить монтирование раздела.

Наслаждаемься нашими разделами с полным доступом на запись чтение и СОЗДАНИЕ файлов.

Алексей aka zlopi

DimkaS

У меня в дебе после установки пакета ntfs-3g и правки fstab само работает. Только ругается постоянно, что ядро 2.6.20 надо. А оно только в unstable есть.

mdog288

у меня ядро 2.6.17 и все прекрасно работает

neGODnick

Я пробовал сделать всё это в SUSE 10? стоящем на VMWare на винде. Почему-то fuse не запускается. То есть у меня получилось всё собрать из исходников, но после редактарования файла fstab разделы винды выглядят пустыми. Начал проверять всё и обнаружил, что служба fuse не запущена. В ясте ставлю «запустить», но после обновления тот же яст показывает, что служба всё равно не запущена.

Heavy

смотри логи, наверняка он там на что-нибудь ругается

neGODnick

Вот ёлки, виртуалка сломалась!!!!!! Как теперь логи посмотришь…

И вообще, что-то у меня создалось впечатление, что VMWare Workstation 6 для Windows работает несколько менее стабильно, чем версия 5. Всё время глюки какие-то.

darkmad88

хотя с 6й версией не работал, может, попробовать удалить все файлы в каталоге ВМ, кроме *.vmx и *.vmdk?