nixp.ru v3.0

22 января 2017,
воскресенье,
17:25:24 MSK

DevOps с компанией «Флант»
stealth написал 26 января 2008 года в 01:34 (296 просмотров) Ведет себя неопределенно; открыл 103 темы в форуме, оставил 124 комментария на сайте.

Dear ALL у меня возникла проблемка.

В системе имеется 2 HDD, SATA 160Gb (на нем установлена система Ubuntu 7.06) и IDE 80Gb.

Проблема в том, что Ubuntu монтирует разделы IDE диска как ro и для доступа к ним запрашивает пароль.

В файле /etc/inittab вообще нет записей относящихся к диску IDE.

Подскажите как сделать разделы диска IDE rw для всех пользователей.

Заранее благодарен

GooglieS

Какая файловая система на IDE винте? Подозреваю что NTFS. Если так, то надо поставить пакетик ntfs-3g и настраивать его. После этого запись в fstab будет выглядить как-то так:

/dev/hda5 /media/metka ntfs-3g rw,nosuid,nodev,noatime,allow_other,nls=utf8, 0 0

PS Убунту 7.04 по умолчанию не имеет установленного пакета ntfs-3g и соотевтсвенно поддержки записи на NTFS диски «из коробки».

stealth

Да именно раздел NTFS IDE диска не монтировался как rw, но пакетик ntfs-3g установлен.

На SATA тоже есть NTFS разделы и с записью на них проблем нет.

Насколько я понял IDE HDD система понимает как внешнее устройство и при попытке доступа к нему запрашивает пароль и выдает что-то типа: «Из соображений безопасности для доступа к внешнему разделу необходмо ввести пароль администратора» (конкретную формулировку не помню а сейчас нет возможности посмотреть, так что извините если не слово в слово, но смысл тот-же). После ввода пароля диск открывается как ro.

Проблема на данный момент уже не актуальна. Нет уже этой системы , но хочется понять в чем была проблема, да и вообще может кому-то в дальнейшем понадобится.

Спасибо ;)

GooglieS

В fstab мою строчку не пробовали добовлять?

stealth

Dear ALL

Вчера столкнулся с такой проблемой: На свежеустановленный Ubuntu 7.10 установил (с помощью Установка/удаление программ) медиа плейер Totem, XMMS player, VLC player и Audacity для редактирования аудио (причем все это установил за один раз и без перезагрузки компа). После перезагрузки Х-ы не стартовали. Просидел перед совершенно черным экраном некоторое время. На нажатия Ctrl+Alt+Backspace, Ctrl+Alt+F1, Ctrl+Alt+Delete система никак не отреагировала и пришлось насильно выключить. Загрузился в безопасном режиме:

/etc/init.d/gdm start -X-ы стартовали, но система выдала следующую ошибку:

failed to initialise HAL при этом не были примонтированы разделы SATA HDD и не работал DVD RW.

Прошу помочь разобраться.

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.