nixp.ru v3.0

19 октября 2017,
четверг,
19:24:49 MSK

DevOps с компанией «Флант»
Maxim Filatov написал 13 октября 2004 года в 15:29 (591 просмотр) Ведет себя как мужчина; открыл 18 тем в форуме, оставил 23 комментария на сайте.

Никак не могу собрать kde на рабочей машине.

Машина: Celeron 1800Mhz/512Mb(DDR400)/32Mb(GeForce2)

USE: USE="gnome -pcmci x86 mmx sse X gtk gtk2 gtkhtml gd-external dba qt wxwindows kde cdr dga fbcon firebird ftp iconv icq imlib ldap pam php perl python apache2 cups samba sasl scanner shared snmp sockets ssl svga truetype usb libwww xml xml2 alsa avi mpeg oggvorbis flac theora xv xvid tiff png jpeg xmms zlib mozilla mysql ncurses nls opengl dvd vhosts»

ACCEPT_KEYWORDS=«~x86»

При сборке kdebase-3.3.1 пишет:

>>> Unpacking source…

* Applying startkde-3.3.1-gentoo.diff…

* Failed Patch: startkde-3.3.1-gentoo.diff!

*

* Include in your bugreport the contents of:

*

* /var/tmp/portage/kdebase-3.3.1/temp/startkde-3.3.1-gentoo.diff-24953.out

!!! ERROR: kde-base/kdebase-3.3.1 failed.

!!! Function epatch, Line 402, Exitcode 0

!!! Failed Patch: startkde-3.3.1-gentoo.diff!

!!! If you need support, post the topmost build error, NOT this status message

Так же не могу собрать kdepim-3.3.0, там оно ругается на gpg(хотя оно стоит) и вылетает….

Если кто-то чем-то может помочь, буду очень признателен.

Заранее спасибо.

P.S. На домашней машине (Duron 1200/768/64) с такими же USE все нормально…..

pol

http://www.linuxshop.ru/forum/viewtopic.php?t=12294

есть такия гипотеза, что пропатчить не получается

«Failed Patch: startkde-3.3.1-gentoo.diff!»

у меня подобная фигня была

«>>> emerge (1 of 16) app-text/tetex-2.0.2-r3 to /

* Adjusting cvs-src permissions for portage user…

>>> md5 src_uri ;-) tetex-src-2.0.2.tar.gz

>>> md5 src_uri ;-) tetex-texmf-2.0.2.tar.gz

>>> md5 src_uri ;-) tetex-texmfsrc-2.0.2.tar.gz

>>> Unpacking source…

>>> Unpacking tetex-src-2.0.2.tar.gz to /var/tmp/portage/tetex-2.0.2-r3/work

>>> Unpacking tetex-texmfsrc-2.0.2.tar.gz to /var/tmp/portage/tetex-2.0.2-r3/wor

k/tetex-src-2.0.2/texmf

>>> Unpacking tetex-texmf-2.0.2.tar.gz to /var/tmp/portage/tetex-2.0.2-r3/work/t

etex-src-2.0.2/texmf

* Applying tetex-2.0.2-dont-run-config.diff… [ ok ]

* Applying tetex-2.0.2.diff… [ ok ]

* Cannot find $EPATCH_SOURCE! Value for $EPATCH_SOURCE is:

*

* /usr/portage/app-text/tetex/files/../../tetex/files/tetex-texdoctk-gentoo.patch

!!! ERROR: app-text/tetex-2.0.2-r3 failed.

!!! Function epatch, Line 249, Exitcode 0

!!! Cannot find $EPATCH_SOURCE!»

pol
http://www.linuxshop.ru/forum/viewtopic.php?t=12294

есть такия гипотеза, что пропатчить не получается

«Failed Patch: startkde-3.3.1-gentoo.diff!»

у меня подобная фигня была

И как лечил?

anonymous

открываешь нужный ebuild и комментишь строку с epatch bla-bla-bla

pol

да ни как не лечил — не понял, что делать да и не кто не знает

пропала надобность после обновления — там используется не патч на старое — а новое!

но проблема всё равно — есть — что не есть гуд!